turbine-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Quinton McCombs" <qmcco...@nequalsone.com>
Subject RE: [SOURCE] Issue #TTWS32 modified
Date Sat, 04 Jan 2003 00:55:20 GMT
I sent out a message after Henning made his changes to the Turbine
servlet to switch to commons-logging.  I had made this change back then.


http://archives.apache.org/eyebrowse/ReadMsg?listName=turbine-dev@jakart
a.apache.org&msgNo=12644

I thought that it got resolved although I just now removed my changes to
verify this and found the problem again.

Here is my web.xml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application
2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>

    <display-name>nequalsone</display-name>
    <description>Version 1.4</description>

    <servlet>
        <servlet-name>nequals1</servlet-name>
        <servlet-class>org.apache.turbine.Turbine</servlet-class>
        <init-param>
            <param-name>properties</param-name>
 
<param-value>/WEB-INF/conf/TurbineResources.properties</param-value>
        </init-param>
    </servlet>

</web-app>

The value for applicationRoot is coming from a constant defined in
org.apache.turtine.TurbineConstants.

    /** Default Value for the Path to the TurbineResources.properties
File */ 
    String APPLICATION_ROOT_DEFAULT =
"/WEB-INF/conf/TurbineResources.properties";
  

> -----Original Message-----
> From: Chris K Chew [mailto:chris@fenetics.com] 
> Sent: Friday, January 03, 2003 5:20 PM
> To: Turbine Developers List
> Subject: RE: [SOURCE] Issue #TTWS32 modified
> 
> 
> > From: Quinton McCombs [mailto:qmccombs@nequalsone.com]
> > I don't really understand what applicationRoot is really 
> used for.  If 
> > someone else that understands this code better could take a look at 
> > this, I would really appreciate it.
> 
> From what I gather, the applicationRoot property allows you 
> >to specify the location of TR.props when it is outside the 
> web context as configured in the container.
> 
> What do you have in your web.xml file for setting the 
> applicationRoot property?  Are you deploying this in a .war file?
> 
> Also, is there a thread in the lists that led up to this 
> scarab issue?  I couldn't find anything in my searches, but 
> would like to know (and
> apologize) if I am missing something.
> 
> Thanks,
> 
> Chris
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:turbine-dev-> unsubscribe@jakarta.apache.org>
> For 
> additional commands, 
> e-mail: <mailto:turbine-dev-help@jakarta.apache.org>
> 
> 


--
To unsubscribe, e-mail:   <mailto:turbine-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:turbine-dev-help@jakarta.apache.org>


Mime
View raw message