trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Di Li <di...@apple.com>
Subject Re: ATS 6.2 Forward Proxy some site has intermitted issue to load
Date Mon, 07 Nov 2016 06:14:40 GMT
does 7.0 production ready yet ?

thought I sort of need to make a decision to either upgrade or downgrade 


Thanks,
Di Li




> On Nov 6, 2016, at 10:11 PM, shrihari kalkar <kshri23@hotmail.com> wrote:
> 
> I believe this is a bug in 6.2.0 release: https://issues.apache.org/jira/browse/TS-4838
<https://issues.apache.org/jira/browse/TS-4838>
> From: di_li@apple.com <di_li@apple.com> on behalf of Di Li <di_li@apple.com>
> Sent: Monday, November 7, 2016 11:04:14 AM
> To: users@trafficserver.apache.org
> Subject: ATS 6.2 Forward Proxy some site has intermitted issue to load
>  
> Hey Guys,
> 
> I’m pretty new in ATS, I have setup ATS 6.2 as a forward proxy, compiled from source,
and running on RedHat 7.2,  the reverse proxy has been disabled.
> 
> I use Firefox as client to test it, and for some reason, I have issues to load some site
for the 1st time, a refresh will fix the issue, but it can be re-produce from time to time
also generate the following traffic.out logs:
> 
> 
> Nov  7 04:13:31 maude-proxy-01 traffic_server[8669]: {0x2aaab6a29700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> Nov  7 04:13:31 maude-proxy-01 traffic_server[8669]: {0x2aaab6b2a700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> Nov  7 04:13:47 maude-proxy-01 traffic_server[8669]: {0x2aaab5a19700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> Nov  7 04:14:04 maude-proxy-01 traffic_server[8669]: {0x2aaab601f700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> Nov  7 04:15:22 maude-proxy-01 traffic_server[8669]: {0x2aaab6726700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> Nov  7 04:15:23 maude-proxy-01 traffic_server[8669]: {0x2aaab7231700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> Nov  7 04:15:23 maude-proxy-01 traffic_server[8669]: {0x2aaab7332700} ERROR: <HttpSM.cc
<http://httpsm.cc/>:1159 (state_raw_http_server_open)> [HttpSM::state_raw_http_server_open]
event: EVENT_INTERVAL state: 0 server_entry: (nil)
> 
> 
> 
> Here’s the picture when it’s happening, the get js should return 304, but somehow
it hangs there.
> 
> and no coredump generated, the traffic_server are not crashed, so far I only have the
log, any suggestion to troubleshooting this issue will be very helpful.
> 
> 
> 
> <PastedGraphic-7.png>
> 
> Thanks,
> Di Li


Mime
View raw message