trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reindl Harald <h.rei...@thelounge.net>
Subject Re: Too many threads
Date Thu, 24 Dec 2015 15:43:50 GMT


Am 24.12.2015 um 16:37 schrieb feng D:
> Thank you, very very very much.
>
> Version: 4.2.3
> OS:        CentOS release 6.5 (Final)  *(kernel is not)*
> Proxy: reverse proxy
>
> I found the different of the five machines. The kernel version of the
> abnormal machines is 3.18.16. The others are 4.1.6. I still not know
> why, but I will find out!!!!!

CentOS 6 dont have any 3.x or 4.x kernel as well as CentOS 6.5 is 
heavily outdated - so WHY in the world don't you upgrade your operating 
system while you play around with kernel versions away from upstream at 
the same time?

what other bad things did you do to your LTS distribution?

[root@honeypot:~]$ uname -r
2.6.32-573.12.1.el6.x86_64

[root@honeypot:~]$ cat /etc/redhat-release
CentOS release 6.7 (Final)

for CentOS 6 EPEL repo provides ATS 5.3.0-1.el6 you are running a 
homebrew 4.2.3 on different homebrew kernels

in other words: you have a total unsupported and untested mess on your 
setups with parts completly outdated and others with much later 
generations than supported - be happy that this boots at all

> 2015-12-24 22:52 GMT+08:00 Reindl Harald <h.reindl@thelounge.net
> <mailto:h.reindl@thelounge.net>>:
>
>
>
>     Am 24.12.2015 um 15:31 schrieb feng D:
>
>         Yes, you are right.  I make a lot of assumptions. I don't know
>         how to reslove this problem. I just has the log as below.
>
>
>     starting with assumptions but nothing about your environment will
>     not help to solve a problem with no software
>
>     FRANKLY you even do not say which version of ATS you are using on
>     what operating system and version - you don't even state if it is
>     actng as forward or reverse proxy
>
>     http://www.catb.org/esr/faqs/smart-questions.html#beprecise
>
>         I want to know why my trafficserver always restart. And I has 5
>         machines. There are three trafficserver that will always
>         restart. The
>         machines are same.
>         The machines with 16G memory. And the thread number of the
>         other two
>         trafficserver is always 18. The config of all is  also same.
>         The ram
>         size is 2G.
>
>         I want to get the direct to find the answer not the answer.
>
>         So, I want to know there questions:
>         1. Was trafficserver start many threads when running?
>         2. Is that the traffic server has two thread called traffic
>         server normal?
>         3. There are many threads called the same name such as [NT_NET
>         8], this
>         is normal?
>         I just has this log:
>
>         ***************************************************************************************
>
>         FATAL: ats_malloc: couldn't allocate 103283 bytes
>
>
>     threads are pretty sure not your problem, that above is a memory
>     allocation error which can be caused by a bug in a system-library or
>     a outdated kernel not handling memeory fragmentation well
>
>     "/usr/local/ats_ssd_422/" makes clear you have a self compiled install
>
>     so how did you ./configure the build?
>
>     our ATS 5.3.2 on Fedora 22/23 x86_64 is built with this options
>     (make soure all relevant devel-packages are installed)
>
>     BuildRequires:     autoconf
>     BuildRequires:     automake
>     BuildRequires:     expat-devel
>     BuildRequires:     gcc-c++
>     BuildRequires:     hwloc-devel
>     BuildRequires:     libtool
>     BuildRequires:     openssl-devel
>     BuildRequires:     pcre-devel
>     BuildRequires:     tcl-devel
>     BuildRequires:     xz-devel
>     BuildRequires:     zlib-devel
>
>     %build
>
>     export CFLAGS="%{optflags} -O3 -fPIC -fPIE
>     -Wno-deprecated-declarations -Wno-error=unused-result -funroll-loops
>     -funswitch-loops -minline-all-stringops"
>
>     export CXXFLAGS="$CFLAGS"
>
>     export LDFLAGS="-Wl,-z,now -Wl,-z,relro,-z,noexecstack -pie
>     %{optflags} -O3 -funroll-loops -funswitch-loops -minline-all-stringops"
>
>     export SH_LDFLAGS="-Wl,-z,now -Wl,-z,relro,-z,noexecstack
>     %{optflags} -O3 -funroll-loops -funswitch-loops -minline-all-stringops"
>
>     ./configure --enable-layout=Gentoo \
>       --libdir=%{_libdir}/%{name} \
>       --with-tcl=%{_libdir} \
>       --with-jemalloc \
>       --with-user=ats \
>       --with-group=ats \
>       --with-pic \
>       --with-xml=expat \
>       --enable-shared  \
>       --enable-hwloc \
>       --disable-debug \
>       --disable-diags \
>       --disable-linux-native-aio \
>       --disable-reclaimable-freelist \
>       --disable-spdy \
>       --disable-static
>     %{__make} %{?_smp_mflags}


Mime
View raw message