trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reindl Harald <h.rei...@thelounge.net>
Subject Re: Upgrade procedure.
Date Wed, 20 Nov 2013 10:20:43 GMT


Am 20.11.2013 11:00, schrieb Vladyslav Bachynskyi:
> On 20.11.2013 11:24, Reindl Harald wrote:
>>
>> Am 20.11.2013 08:04, schrieb Vladyslav Bachynskyi:
>>> Could someone please advise me on proper upgrade procedure for ATS.
>>>
>>> I have 4.0.1 instance installed under:
>>> /opt/trafficserver-4.0.1
>>>
>>> I've compiled the new 4.1.1 under:
>>> /opt/trafficserver-4.1.1
>> ouch - you should build packages so that you could
>> do *clean* updates / downgrades
>>
>>> I've copied all configs from /opt/trafficserver-4.0.1/etc/trafficserver/* to
newly installed 4.1.1, and after I
>>> started the new version of ATS I can see in logs that all objects which was HITed
before, now are MISSed.
>>> When I switched back to previous version (4.0.1), all objects which was HITed
before are HITed now as well.
>>>
>>> What I'm doing wrong?
>> look in the logfiles, normally /var/log/trafficserver/
> 
> Nothing special in logs:
> 
> diags.log:
> 
> [Nov 19 16:30:36.053] {0x2b499f3be3c0} STATUS: opened
> /opt/trafficserver/var/log/trafficserver/diags.log
>
>>> I could not found the upgrade procedure in docs and wiki, please, give me a link,
If it's exists
>> for 4.0 to 4.1 there is no change needed
> 
> So I can just install the new version over previous, and everything
> should work fine?

yes, but that is why i *strongly* recommend to build *packages*
RPM removes obsolete files and you have always a clean install
you should never install compilers on servers and build packages on isolated environment with
a restricted user
a plain "make install" is the root of all evil on a server over the long


Mime
View raw message