trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mars...@gmail.com
Subject Re: error: the requested command failed when trying to run /usr/bin/traffic_line -x
Date Wed, 07 Aug 2013 13:07:41 GMT
Thanks for explaining. I am new to trafficserver too. I never tried to run it as a service.
I run trafficserver as root and the trafficserver executables are in that user's PATH. It
seems like it cannot find the executable at all. Try "which trafficserver" command and check
your path.
FYI the trafficserver logs: /usr/local/var/log/trafficserver
-----Original Message-----
From: Noam Schiff <noamschiff@gmail.com>
Date: Wed, 7 Aug 2013 15:33:13 
To: <users@trafficserver.apache.org>; <marswrk@gmail.com>
Subject: Re: error: the requested command failed when trying to run
 /usr/bin/traffic_line -x

My executable trafficserver file are under /usr/bin, but when I'm trying to
run the trafficserver start command it says command not found.
So when I'm saying some progress I meant that when I typed "service
trafficserver start" I got the prompt "* Not starting Apache Traffic Server"

On Wed, Aug 7, 2013 at 3:21 PM, <marswrk@gmail.com> wrote:

> **
> It helps if you give background on your setup. /usr/local/bin is the
> default location for installation of executables for trafficserver. This
> should be in the default PATH for the user running trafficserver. As thar
> user "which trafficserver" might show your location.
>
> By progress do you mean your original question is answered and the command
> line works now?
> ------------------------------
> *From: * Noam Schiff <noamschiff@gmail.com>
> *Date: *Wed, 7 Aug 2013 12:39:07 +0300
> *To: *<users@trafficserver.apache.org>
> *ReplyTo: * users@trafficserver.apache.org
> *Subject: *Re: error: the requested command failed when trying to run
> /usr/bin/traffic_line -x
>
> There is some progress...
> But, when I'm running
> /usr/bin# sudo service trafficserver start
>  * Not starting Apache Traffic Server
>
> I'm getting this message. Does anyone know why I'm getting this message?
>
>
> On Wed, Aug 7, 2013 at 12:05 PM, Noam Schiff <noamschiff@gmail.com> wrote:
>
>> Could you please send me the path to this command?
>>
>>
>> On Wed, Aug 7, 2013 at 11:17 AM, Nick Kew <niq@apache.org> wrote:
>>
>>> On 7 Aug 2013, at 09:04, Noam Schiff wrote:
>>>
>>> > Does killing the process and running the command
>>> /usr/bin/traffic_server start & does the trick?
>>>
>>> Is that a typo?
>>>
>>> traffic_server (with the underscore) is the main daemon process.
>>> trafficserver (no underscore) is the command to use with arguments like
>>> "start"
>>>
>>> The latter also starts the manager that responds to traffic_line !
>>>
>>> --
>>> Nick Kew
>>
>>
>>
>

Mime
View raw message