trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Heitor Ganzeli <hei...@nic.br>
Subject ICP
Date Tue, 23 Oct 2012 20:36:33 GMT
Hello everyone,
I'm trying, without much success, to setup an ATS instance with ICP
enabled. In the beginning I tried to use the 3.2 version hoping it would
have at least some of its functionality then I went to the version 2.0.1
and I've also fail to set it up.

the configuration specifically related to ICP is:

CONFIG proxy.config.http.quick_filter.mask INT 2147614866CONFIG
proxy.config.icp.enabled INT 2
CONFIG proxy.config.icp.icp_interface STRING eth0
CONFIG proxy.config.icp.icp_port INT 3130
CONFIG proxy.config.icp.multicast_enabled INT 0
CONFIG proxy.config.icp.query_timeout INT 2

and I'm also logging dubug information about ICP:
CONFIG proxy.config.diags.debug.tags STRING icp.*

When I start ATS, the traffic_server starts to fail in a loop. The
traffic.out output is:
[TrafficServer] using root directory '/usr/local'
[Oct 23 18:13:29.763] {1081635264} STATUS: opened
var/log/trafficserver/diags.log
[Oct 23 18:13:29.798] Server {1081635264} DEBUG: (icp) On=2,
MultiCast=0, Timeout=2 LocalCacheLookup=0
[Oct 23 18:13:29.798] Server {1081635264} DEBUG: (icp) StaleLookup=0,
ReplyToUnknowPeer=0, DefaultReplyPort=0
[Oct 23 18:13:29.798] Server {1081635264} DEBUG: (icp) [0]: Type=L
IP=192.168.56.101 Port=3130 PPort=0 Host=localhost
[Oct 23 18:13:29.798] Server {1081635264} DEBUG: (icp) [0]: MC ON=0
MC_IP=0.0.0.0 MC_TTL=0
[Oct 23 18:13:29.798] Server {1081635264} DEBUG: (icp) [1]: Type=S
IP=192.168.56.102 Port=3130 PPort=8080 Host=host2
[Oct 23 18:13:29.798] Server {1081635264} DEBUG: (icp) [1]: MC ON=0
MC_IP=0.0.0.0 MC_TTL=1
NOTE: Traffic Server received Sig 11: Segmentation fault
/usr/local/bin/traffic_server - STACK TRACE:
[Oct 23 18:13:29.882] Manager {3070949696} ERROR:
[LocalManager::pollMgmtProcessServer] Server Process terminated due to
Sig 11: Segmentation fault
[Oct 23 18:13:29.882] Manager {3070949696} ERROR:  (last system error 2:
No such file or directory)
[Oct 23 18:13:29.882] Manager {3070949696} ERROR: [Alarms::signalAlarm]
Server Process was reset
[Oct 23 18:13:29.882] Manager {3070949696} ERROR:  (last system error 2:
No such file or directory)
[TrafficServer] using root directory '/usr/local'
[Oct 23 18:13:31.920] {1081635264} STATUS: opened
var/log/trafficserver/diags.log

I've also tried the same configurantion file but turning off ICP and it
works just fine.
I'm running that inside a virtual machine instance of a UBUNTU 12.04 32bits

Finally I'd like to ask if anyone has faced a problem like this or have
a working ICP configuration that I could use in my tests.


thanks,
Heitor de Souza Ganzeli



>


Mime
View raw message