trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danny Shporer" <Dan...@Radware.com>
Subject ATS crashes under heavy load
Date Wed, 12 Oct 2011 13:48:09 GMT
Hi

 

I have been experiencing ATS crashes under heavy load testing - around
25,000 HTTP transactions per second.

The environment is a 4 core desktop running Centos 5.6, kernel 2.6.39.2
compiled with TPROXY support. ATS runs as a transparent proxy.

ATS was compiled with the following options:  ./configure
--enable-tproxy --enable-libev

ATS version of this info is 3.0.0 (I have tested it on 3.0.1 as well and
the same happens).

 

Attached is the records.config of ATS

 

 

Following is the gdb info:

 

Program received signal SIGSEGV, Segmentation fault.

[Switching to Thread 0x42174940 (LWP 6663)]

0x000000000068fd4b in modify (this=0x2aaaab12c628, event=<value
optimized out>, e=<value optimized out>) at P_UnixNet.h:536

536         fd_change(event_loop->eio, eio.fd, 0);

(gdb) bt

#0  0x000000000068fd4b in modify (this=0x2aaaab12c628, event=<value
optimized out>, e=<value optimized out>) at P_UnixNet.h:536

#1  NetHandler::mainNetEvent (this=0x2aaaab12c628, event=<value
optimized out>, e=<value optimized out>) at UnixNet.cc:432

#2  0x00000000006bfc4f in EThread::process_event (this=0x2aaaab12b010,
e=0xf44570, calling_code=5) at I_Continuation.h:146

#3  0x00000000006c055c in EThread::execute (this=0x2aaaab12b010) at
UnixEThread.cc:262

#4  0x00000000006bef8e in spawn_thread_internal (a=0xf35c90) at
Thread.cc:88

#5  0x0000003e9dc0673d in start_thread () from /lib64/libpthread.so.0

#6  0x0000003e9d0d44bd in clone () from /lib64/libc.so.6

(gdb) info f

Stack level 0, frame at 0x42174030:

rip = 0x68fd4b in modify (P_UnixNet.h:536); saved rip 0x6bfc4f

inlined into frame 1

source language c++.

Arglist at unknown address.

Locals at unknown address, Previous frame's sp in rsp

 

 

Thanks

Danny

 

 


Mime
View raw message