trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan M. Carroll" <...@network-geographics.com>
Subject Re: Error could not find server
Date Wed, 25 May 2011 15:48:06 GMT
I think that's actually a bug in the logging (which I thought I fixed for 
2.1.8).

Anyway, I suspect at this point that it's a result of using client side 
transparency for the other server ports. Facebook will see all the requests 
coming from a single IP address (that of the ATS box) and eventually it's 
access times out and doesn't get renewed. I would recommend changing from ':>' 
to ':=' on the other ports for this line

CONFIG proxy.config.http.server_other_ports STRING 3128:>

The half transparency cases are not yet well tested.

Unfortunately, I will be leaving for 2 weeks this weekend and will have very 
little electronic contact. I am currently focused on another ATS project and 
can't devote much time to this until then.


Wednesday, May 25, 2011, 10:21:40 AM, you wrote:

> On 05/25/2011 09:17 AM, Alvin Alexander Utomo wrote:
>> My ATS shows errors like this :
>>
>> 20110525.21h59m39s RESPONSE: sent 202.95.137.5 status 502 (Cannot find 
>> server.) for 'http:///ajax/session.php?__a=1'
>> 20110525.21h59m39s RESPONSE: sent 202.95.137.5 status 502 (Cannot find 
>> server.) for 'http:///ajax/apps/usage_update.php?__a=1'
>> 20110525.21h59m39s RESPONSE: sent 202.95.137.6 status 502 (Cannot find 
>> server.) for 'http:///ajax/chat/buddy_list.php?__a=1'
>> 20110525.21h59m39s RESPONSE: sent 202.95.137.6 status 502 (Cannot find 
>> server.) for 'http:///fbml/fbjs_ajax_proxy.php?__a=1'
>> 20110525.21h59m41s RESPONSE: sent 202.95.137.6 status 502 (Cannot find 
>> server.) for 'http:///ajax/chat/buddy_list.php?__a=1'

> I know there have been reports of some broken logs issues with 
> transparent proxy, so it's difficult to tell here. I mean, the log 
> indicates that there would be not Host: header in the request I think.  
> However, as far as I can tell, the errors above would only happen if DNS 
> failed for us. I'm curious, does restarting the server "resolve" the issue?

> -- Leif



Mime
View raw message