trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Walsh, Peter" <Peter.Wa...@disney.com>
Subject release 2.0.1 make errors.
Date Fri, 08 Apr 2011 18:02:23 GMT
Hello,
I recently downloaded the stable release 2.0.1 however I got the following
make errors...

UnixNet.cc: In function Œvoid initialize_eventfd(EThread*)¹:
UnixNet.cc:141: error: aggregate Œepoll_event ev¹ has incomplete type and
cannot be defined
UnixNet.cc:142: error: invalid application of Œsizeof¹ to incomplete type
Œepoll_event¹ 
UnixNet.cc:144: error: ŒEPOLLIN¹ was not declared in this scope
UnixNet.cc:144: error: ŒEPOLLET¹ was not declared in this scope
UnixNet.cc:146: error: Œstruct PollDescriptor¹ has no member named
Œepoll_fd¹
UnixNet.cc:146: error: ŒEPOLL_CTL_ADD¹ was not declared in this scope
UnixNet.cc:146: error: Œepoll_ctl¹ was not declared in this scope


I also downloaded the unstable release 2.1.7 and followed the same steps
and it built successfully.

Has anyone else experienced similar issues when building 2.0.1?

I'm building on Mac Os x, 10.6.6, with gcc 4.2.1

-Pete


Mime
View raw message