trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: reverse_map not happening as expected
Date Sun, 20 Feb 2011 16:48:30 GMT


----- Original Message -----
> I have ATS in front of HAProxy clustering Tomcat 7. For legacy
> reasons the app on tomcat does a redirect with a hostname hard-coded
> in it, so I've been trying to write reverse_map directives to work
> around it:
> 
> --- remap.config ---
> reverse_map http://naznet1.naz.edu/nazdev/nazdev http://proxy-host
> reverse_map http://127.0.0.1:10000/nazdev/nazdev http://proxy-host
> 
> map http://proxy-host http://127.0.0.1:10000/nazdev/nazdev
> --------------------
> 
> If I request http://proxy-host in a browser or via curl, I get these
> headers:
> 
> --- headers ---
> HTTP/1.1 302 Moved Temporarily
> Server: ATS/2.1.5-unstable
> Pragma: no-cache
> Cache-Control: no-cache;no-store
> Location:
> HTTP://naznet1.naz.edu:80/nazdev/nazdev?TYPE=M&PID=CORE-WBMAIN
> Content-Type: text/html;charset=utf-8
> Content-Length: 0
> Date: Sun, 20 Feb 2011 13:40:39 GMT
> Set-Cookie: serverid=nn01; path=/
> Age: 0
> Connection: keep-alive
> ---------------
> 
> Shouldn't ATS have rewritten the Location to reflect my
> reverse_mapping? What did I miss?

What's your setting for proxy.config.url_remap.pristine_host_hdr _
 
> Best wishes,
> Michael A. Smith
> Web & Digital / Academic Technologies Manager
> Nazareth College


i

-- 
Igor Galić

Tel: +43 (0) 664 886 22 883
Mail: i.galic@brainsware.org
URL: http://brainsware.org/

Mime
View raw message