trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: HTTP 502 for SSL connections
Date Thu, 03 Feb 2011 16:57:12 GMT

----- "Dave Eagen" <David.Eagen@biworldwide.com> wrote:

> We are trying out Traffic Server and have run into a problem with SSL

Which version of ATS are you running, which version of OpenSSL?

> connections made through it. Most of the time the connections work
> fine (HTTP 200) but sometimes an HTTP 502 is reported. This is
> happening on requests to the same destination URL.
> 
> If instead of running Traffic Server we run Squid (on the same
> physical machine) we never get the 502 errors. We have confirmed that
> the 502's did not happen because of actual connectivity problems with
> the site we are attempting to access.
> 
> Where can I start looking to figure out why these 502's are happening
> with Traffic Server but not Squid?
> 
> Failure example logs:
> 
> 
> Error example:
> 
> (squid.blog)
> 
> 1296576007.087 58 1.2.3.4 ERR_CONNECT_FAIL/502 454 CONNECT
> xxx.yyy.com:443/ - DIRECT/xxx.yyy.com text/html -
> 
> (error.log)
> 
> 20110201.10h00m07s RESPONSE: sent 1.2.3.4 status 502 (Tunnel
> Connection Failed) for 'xxx.yyy.com:443/'
> 
> 
> 
> Success example:
> 
> (squid.blog)
> 
> 1296576041.850 116107 1.2.3.4 TCP_MISS/200 103 CONNECT
> xxx.yyy.com:443/ - DIRECT/xxx.yyy.com - -
> 
> 
> 
> 
> 
> -Dave

i

-- 
Igor Galić

Tel: +43 (0) 664 886 22 883
Mail: i.galic@brainsware.org
URL: http://brainsware.org/

Mime
View raw message