trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: traffic_server get a segfault when ICP is enabled
Date Tue, 26 Oct 2010 09:54:14 GMT

----- he <husthj@yahoo.com> wrote:
> Thanks for the replies. Just FYI, I tested 2.1.3 on the same box without coredump in
startup.
> 
> BTW, how to get a core file for traffic server? I try to reconfigure with --enable-debug,
make, make install and set ulimit -c unlimited before start up 2.0.1, but I can't find the
core file. Can you give some advise? 

Easiest way will be to explicitly set the core dump directory in the Kernel

On Linix that's sys.kernel.core_pattern
On Solaris with coreadm and on FreeBSD kern.corefile
 
> howard
> 
> --- 10年10月24日,周日, Leif Hedstrom <zwoop@apache.org> 写道:
> 
> > 发件人: Leif Hedstrom <zwoop@apache.org>
> > 主题: Re: traffic_server get a segfault when ICP is enabled
> > 收件人: users@trafficserver.apache.org
> > 抄送: "he" <husthj@yahoo.com>
> > 日期: 2010年10月24日,周日,上午1:25
> >  On 10/22/2010 03:53 AM, he wrote:
> > > I have a ts-2.0.1 stable installed on a Linux node. It
> > works fine in single mode. But when I enable ICP,
> > traffic_server gets a segfault during start.
> > > 
> > > I have a line
> > > ts1:10.161.29.89:2:8080:3130:0:0.0.0.0:1:
> > > in icp.config
> > > 
> > > (10.161.29.89 is another node running ts-2.0.1)
> > 
> > 
> > I'm fairly certain that the ICP code is not completely
> > functional in the current trunk. I think the plan is / was
> > to address this after the v2.2 release (together with fixing
> > the Clustering bugs).
> > 
> > Caveat: I haven't tested ICP in a long time, but I suspect
> > it was broken when we migrated to epoll / kqueue.
> > 
> > -- Leif
> > 
> > https://issues.apache.org/jira/browse/TS-32
> > 
> 
> 
> 

-- 
Igor Galić

Tel: +43 (0) 664 886 22 883
Mail: i.galic@brainsware.org
URL: http://brainsware.org/

Mime
View raw message