trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick McManus <mcma...@ducksong.com>
Subject plugin using INKHttpTxtIntercept() fails on "could not connect to 0.0.0.0"
Date Wed, 27 Oct 2010 14:48:38 GMT
Hi all - I'm a bit stymied and I'm hoping someone can give me a clue.. I
am trying to use INKHttpTxnIntercept in a plugin but TS keeps giving
errors related to trying to make a back end connection (which is what
this seeks to avoid).

I've called:

contp = INKContCreate (fx, INKMutexCreate());
INKHttpTxnIntercept(contp, txnp);

fx recevies net_accept, read_ready, and read_complete. (in read_ready I
do a INKVIONBytesSet on the input bufer in order to get the
read_complete)

before read_complete is done, I setup an output buffer and write a good
response into it and then call INKVConnClose() .. if I don't call
ConnClose() the whole transaction hangs.

unfortunately instead of receving my http response, the client receives
this:

HTTP/1.1 502 Server Hangup
Date: Wed, 27 Oct 2010 13:07:38 GMT
Connection: keep-alive
Via: HTTP/1.1 <proxy_name> (ApacheTrafficServer/2.0.0 [c sEf ])
Server: ATS/2.0.0
Cache-Control: no-store
Content-Type: text/ht
Content-Language: en
Content-Length: 198

<HEAD><TITLE>Server Hangup</TITLE></HEAD>
<BODY BGCOLOR="white" FGCOLOR="black">
<FONT FACE="Helvetica,Arial"><B>
 Server Hangup</B></FONT>

<!-- default "Server Hangup" response (502) -->
</BODY>

and I get this in my log:
20101027.10h27m51s CONNECT: could not connect to 0.0.0.0 for 'THEURL' (setting last failure
time)
20101027.10h27m51s RESPONSE: sent 127.0.0.1 status 502 (Server Hangup) for 'THEURL'

help?


Mime
View raw message