trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pranav Desai <>
Subject Re: errors and shutdown message in 2.1.2 under load (TS-441)
Date Tue, 21 Sep 2010 01:20:27 GMT
On Thu, Sep 16, 2010 at 3:30 PM, Pranav Desai <> wrote:
> On Thu, Sep 16, 2010 at 2:03 PM, Leif Hedstrom <> wrote:
>> On 09/16/2010 02:45 PM, Pranav Desai wrote:
>> On Thu, Sep 16, 2010 at 12:33 PM, Leif Hedstrom <> wrote:
>>  On 09/16/2010 01:26 PM, Pranav Desai wrote:
>> Hi!
>> I am running a load test with some video files to see . I am using
>> curl-loader to generate the load. I have modified it to add a random
>> number to the URLs before sending so I can test with a single URL and
>> still stress the cache. The webserver is a lighttpd server with
>> rewrite rules to translate the random strings back to a common URL.
>> The URL is essentially a 15MB video file. I can provide more details
>> on the setup if needed.
>> Ok, I've created   with this
>> information. If you can find a core file (or, run traffic_server under gdb),
>> and get a stack trace, that would be very helpful. Also, when it crashes,
>> you might get a stack trace in /var/log/messages and/or one of the log files
>> in the .../var/log/trafficserver  directory.

I got the stack trace. I have updated the bug with the trace, but here it is.

FATAL: failed assert `!"unknown m_polarity"`
./bin/traffic_server - STACK TRACE:

I will try to dig deeper, but if have any ideas or suggestions I can
try those out.

-- Pranav

View raw message