trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pranav Desai <pranavade...@gmail.com>
Subject Re: ram_cache size > 2GB
Date Wed, 15 Sep 2010 21:35:59 GMT
On Fri, Sep 10, 2010 at 7:22 PM, Leif Hedstrom <zwoop@apache.org> wrote:
> Please try v2.1.2. Note that as of this version the ram cChe settings are of
> INT type in records.config (but they are all 64-bit ints).
>


I tried to use 2.1.2. But it doesnt seem to run for me.

./bin/trafficserver start
says ok
but only traffic_cop is running.

I tried to start traffic_manager by hand. This is the output.
[root@c1b14 ats2]# ./bin/traffic_manager
[E. Mgmt] log ==> [TrafficManager] using root directory '/usr/local/ats2'
[Sep 15 14:17:40.146] {140131646002992} STATUS: opened
/usr/local/ats2/var/log/trafficserver/manager.log

There is not much in the manager.log.

./bin/traffic_server runs ok, but I cant use the traffic_shell. It
complains about traffic_manager errors.

ERROR: Timed-out while communicating with traffic_manager.
       Ability to make configuration changes depends on traffic_manager.

I am using it as an explicit proxy and after starting traffic_server
it does serve the request and I even get a hit on subsequent request,
but after sending a few request it started giving the following error
and died eventually.

-------------- End header heap dump -----------
WARNING: Unmarshal failed due to unknow obj type 98 after 776
bytes---- Dumping header heap @ 0x7fe82161a810 - len 1209 ------
0x7fe82161a810: 0xdcbafeed 0x57074c98 0x2161ab88 0x7fe8
0x7fe82161a820: 0x2161a898 0x7fe8 0x378 0x5834f600


Any thoughts ?

Thanks
-- Pranav

> -- leif
> On Sep 10, 2010, at 7:48 PM, Pranav Desai <pranavadesai@gmail.com> wrote:
>
> Hi!
>
> I am trying to experiment with the performance of ATS for large video
> files. ATS version is:
>
> Apache Traffic Server - traffic_server - 2.0.1 - (build # 8912 on Sep
> 9 2010 at 12:08:29)
>
> I tried to set the ram_cache to > 2GB, it doesn't complain but the
> "show:cache-stats" command in the CLI give a negative value. Is that a
> CLI data type issue while reporting the size, or does the system not
> support > 2GB RAM ?
>
> Let me know if I you need some other information or if I have missed
> something.
>
> Thanks for your help.
>
> -- Pranav
>

Mime
View raw message