trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zachary Miller <zacharymmil...@gmail.com>
Subject Cache Behavior: not caching all responses
Date Tue, 06 Apr 2010 22:50:52 GMT
Hi,

I am having some trouble getting Traffic Server to cache all of the content
that it encounters.  For instance, when I inspect the cache none of the
following URLs appear:


1270592980.711 398 192.168.215.92 TCP_MISS/200 19711 GET
http://www.dickssportinggoods.com/product/index.jsp?productId=2805051 -
DIRECT/www.dickssportinggoods.com text/html -
1270592980.876 323 192.168.215.92 TCP_MISS/200 19458 GET
http://www.dickssportinggoods.com/product/index.jsp?productId=2805083 -
DIRECT/www.dickssportinggoods.com text/html -
1270592981.051 388 192.168.215.92 TCP_MISS/200 19811 GET
http://www.dickssportinggoods.com/product/index.jsp?productId=3801787 -
DIRECT/www.dickssportinggoods.com text/html -


There are thousands more like that (and this is after I have already run
through all of these URLs previously), and none of them have been cached (or
at least none of them appear when searched for), even though they are
definitely running through Traffic Server (the above URLs come directly from
squid.log).  JavaScript and other types of content are being served (ex:
http://www.dickssportinggoods.com/foresee/foresee-alive.js<http://ts.cache/lookup_regex?url=http%3A%2F%2Fwww.*#>),
but not the text and html documents.

I have the records.config setting 'CONFIG
proxy.config.http.cache.cache_urls_that_look_dynamic INT 1' set.

I'm suspecting that I'm missing something very obvious in the configuration,
and attached is my records.config.

I would really appreciate the help and am nearly at wits end on this.

Thanks so much in advance,

Zachary

Mime
View raw message