trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rusty Conover <rcono...@infogears.com>
Subject Re: Basic Questions
Date Tue, 03 Nov 2009 15:02:05 GMT
Hi Guys,

First thanks for all of your help.

On Nov 3, 2009, at 12:44 AM, Leif Hedstrom wrote:

>
> On Nov 2, 2009, at 9:43 PM, Rusty Conover wrote:
>
>> Hi,
>>
>> I'm trying to get traffic server up and running for some testing.   
>> I have a few questions:
>>
>> 1. Is traffic_manager supposed to work?  There doesn't appear to be  
>> any real way to know which script should start the whole collection  
>> of programs.  Maybe I'm just missing it.
>

Okay I'll just ignore it for now.

> You want to play with the traffic_server binary. There is an help  
> page for it if you run it with --help. The "best" option for  
> debugging / testing is -T. E.g. to show all tracer messages related  
> to http, you can run it with
>
>     /usr/local/bin/traffic_server -T http.*
>
> (the argument is a regex).

This works great.  I'm getting some responses, from the traffic_server  
and plan to just go on from here.

One thing, it doesn't appear that the Content-Type header is being  
properly set on the body_factory responses.  But I'll look into it.

Is there a way to set a negative regexp for debugging, ideally I don't  
need to see all of the epoll and iocore lines.

Thanks,

Rusty
--
Rusty Conover
rconover@infogears.com
InfoGears Inc / GearBuyer.com / FootwearBuyer.com
http://www.infogears.com
http://www.gearbuyer.com
http://www.footwearbuyer.com


Mime
View raw message