trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Call <bc...@yahoo-inc.com>
Subject Re: glibc-devel required?
Date Wed, 04 Nov 2009 19:46:00 GMT
You will have to install the equivalent packages that are in RHEL4.   
Our main production build environment is RHEL4, so after installing  
the required packages it should compile without problems.

On my RHEL4 32bit server, these are the glibc packages I have installed:

[yts_dev bcall@armybright ~]$ rpm -qa | grep glibc
glibc-common-2.3.4-2.41
glibc-headers-2.3.4-2.41
glibc-2.3.4-2.41
glibc-kernheaders-2.4-9.1.103.EL
glibc-devel-2.3.4-2.41

[yts_dev bcall@armybright ~]$ cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)

-Bryan

On Nov 4, 2009, at 3:38 AM, ios firefox wrote:

> Hi, everyone,
>     I am trying to use traffic server, but when I execute the  
> command "./configure", something happens as follows:
> --------------------------------------------------------------
> checking for regcomp in -lregex-3.6... no
> checking for exc_capture_context in -lexc... no
> checking for MLD_demangle_string in -lmld... no
> checking for crypt in -lcrypt... no
> checking for dlopen in -ldl... no
> checking for XML_SetUserData in -lxml... no
> checking for socket in -lsocket... no
> checking for gethostbyname in -lnsl... no
> checking for res_init in -lresolv... no
> checking for __putlong in -lresolv... no
> checking for pthread_exit in -lpthread... no
> checking for clock_gettime in -lrt... no
> checking for clock_gettime in -lposix4... no
> checking for gnu_get_libc_version... no
> configure: error: check for glibc failed. Have you installed glibc- 
> devel?
> --------------------------------------------------------------
>
>     and I found something in the README:
> --------------------------------------------------------------
> 3. REQUIREMENTS
>   Fedora 11:
>     gcc-c++
>     glibc-devel.i586
>     db4-devel.i586
>     openssl-devel.i586
>     tcl-devel.i586
>     expat-devel.i586
> --------------------------------------------------------------
>
>     I already have gcc & glibc on my system, and my system is Red  
> Hat Enterprise Linux AS release 4 (Nahant Update 3)
>
>     Does it mean I must install all the rpm above?
>
>     I am not root user, how can i install traffic server in this  
> situation, just from source code, without all the rpm?



Mime
View raw message