trafficserver-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Hedstrom <zw...@apache.org>
Subject [ANNOUNCE] ATS v7.0.0 will require gcc 4.8.1 (or later / compatible) for C++11
Date Thu, 21 Jul 2016 21:14:01 GMT
Hi all,

as discussed on the mailing lists before, we are going to require C++11 for v7.0.0 and going
forward. This means that for some platforms, e.g. CentOS6, you will need to use a newer developer
toolset. For example, devtoolset-[34]:

	https://www.softwarecollections.org/en/scls/rhscl/devtoolset-3/
	https://www.softwarecollections.org/en/scls/rhscl/devtoolset-4/

(or, you can of course manage your own build tools).

We have changed the CI for CentOS6 to use devtoolset-3 for master and going forward. It’s
a little unclear yet what this means for Ubuntu-12.04, hopefully there’s a PPA that can
provide similar tools there as well.

Cheers,

— leif



Mime
View raw message