trafficserver-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yunkai Zhang <yunkai...@gmail.com>
Subject Re: buildbot failure in ASF Buildbot on tserver-trunk-debug
Date Sun, 03 Feb 2013 17:06:57 GMT
On Sun, Feb 3, 2013 at 8:36 PM, Igor Galić <i.galic@brainsware.org> wrote:

> On Sunday, February 03, 2013 10:45:23 AM buildbot@apache.org wrote:
> > The Buildbot has detected a new failure on builder tserver-trunk-debug
> while
> > building trafficserver. Full details are available at:
> >  http://ci.apache.org/builders/tserver-trunk-debug/builds/1171
>
>
> Impressive:
>
> FATAL: ink_queue.cc:221: failed assert
> `!((uintptr_t)TO_PTR(FREELIST_POINTER(item))&(((uintptr_t)f->alignment)-1))`
> ats-install/bin/traffic_server - STACK TRACE:
>
> /home/buildslave1/slave1/tserver-trunk-debug/build/ats-install/lib/libtsutil.so.3(ink_fatal_die+0x0)[0x7f29c71e1012]
>
> /home/buildslave1/slave1/tserver-trunk-debug/build/ats-install/lib/libtsutil.so.3(ink_get_rand()+0x0)[0x7f29c71dff6c]
>
> /home/buildslave1/slave1/tserver-trunk-debug/build/ats-install/lib/libtsutil.so.3(ink_freelist_new+0x3cc)[0x7f29c71e5b33]
>
> ats-install/bin/traffic_server(ClassAllocator<ProxyMutex>::alloc()+0x1b)[0x4cc603]
> ats-install/bin/traffic_server(new_ProxyMutex()+0x12)[0x4ca78d]
> ats-install/bin/traffic_server(Thread::Thread()+0x34)[0x70c740]
> ats-install/bin/traffic_server(EThread::EThread()+0x1b)[0x70ceaf]
> ats-install/bin/traffic_server(main+0x35e)[0x515487]
> /lib/libc.so.6(__libc_start_main+0xfd)[0x7f29c4d3cc4d]
> ats-install/bin/traffic_server[0x4c85f9]
> process killed by signal 6
> program finished with exit code -1
>
> it dies on startup :\
>

I'll try to fix it tomorrow.


>
> > Buildbot URL: http://ci.apache.org/
> >
> > Buildslave for this Build: ceres_ubuntu
> >
> > Build Reason: scheduler
> > Build Source Stamp: [branch master]
> afe372a6f016202277d25d9e916ba369de860bc6
> > Blamelist: Yunkai Zhang <qiushu.zyk@taobao.com>,Zhao Yongming
> > <ming.zym@gmail.com>
> >
> > BUILD FAILED: failed compile_6
> >
> > sincerely,
> >  -The Buildbot
>



-- 
Yunkai Zhang
Work at Taobao

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message