trafficserver-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Hedstrom <zw...@apache.org>
Subject Re: Never seem to get a cache hit
Date Tue, 19 Jul 2011 22:57:17 GMT
If I read that right, that response is not cacheable with default ATS configs. Look for required
headers config in records.config, or ideally modify the origin to send cache-control headers.

-- leif

On Jul 19, 2011, at 1:11 PM, "Alan D. Cabrera" <list@toolazydogs.com> wrote:

> 
> On Jul 19, 2011, at 12:06 PM, Igor Galić wrote:
> 
>> 
>> 
>> ----- Original Message -----
>>> I reran my program twice which gets the same set of files but I'm
>>> getting 100% miss rate.  I have 1G cache in memory and 10G disk.
>>> I'm downloading about 15M of files.
>>> 
>>> What should I be looking at to debug this?
>> 
>> What do the headers of your back-ends look like?
> 
> Request URL:http://foo.com:8081/artifactory/release/com/foo/bar/bar/bar-api/6.6.6/bar-api-6.6.6.jar.sha1
> Request Method:GET
> Status Code:200 OK
> Request Headers
> Accept:text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
> Accept-Charset:ISO-8859-1,utf-8;q=0.7,*;q=0.3
> Accept-Encoding:gzip,deflate,sdch
> Accept-Language:en-US,en;q=0.8
> Connection:keep-alive
> Cookie:bcookie="v=1&";
> Host:foo.com:8081
> User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/534.30 (KHTML,
like Gecko) Chrome/12.0.742.112 Safari/534.30
> Response Headers
> Content-Length:40
> Content-Type:application/x-checksum
> Date:Tue, 19 Jul 2011 20:06:43 GMT
> Last-Modified:Tue, 19 Jul 2011 20:06:44 GMT
> Server:Artifactory/2.3.1
> 

Mime
View raw message