trafficserver-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Hedstrom <zw...@apache.org>
Subject Re: Does Web2 actually works?
Date Sat, 15 May 2010 11:35:55 GMT
On 05/15/2010 01:29 AM, Mladen Turk wrote:
> Hi,
>
> Documentation says that
> "Note that the web interface is not being maintained."
>
> However enabling
> CONFIG proxy.config.diags.debug.tags STRING http.*|ui.*|web2.*
>
> Shows:
> Manager {3054115728} DEBUG: (ui) [WebIntrMain] Starting up Web Server 
> on Port 8081
> Manager {3054115728} DEBUG: (ui) SSL enabled is 0
> Manager {3054115728} DEBUG: (ui) [WebIntrMain] Starting Client 
> AutoConfig Server on Port 8083
>
> Nevertheless the `netstat -p | grep traffic` shows nothing listening 
> on the port 8081
> neither the log shows any error messages.
>
> Am I missing something obvious?

No :). The GUI is disabled by default, there's an option to turn it on, 
but last I tried, I couldn't even login to it. We're seriously thinking 
of removing the GUI completely,  we really don't like how it's 
integrated into "traffic_manager", it ought to be a standalone GUI built 
on top of Apache or something. My personal preference would be to nuke 
all of the GUI, and if someone is interested, we do a complete rewrite 
using modern tools (Apache HTTPD + other tools).

We'd still need to keep the CLI part of the management system though, to 
expose an API for a Web GUI (and other monitoring tools) to be built on 
top of.

-- Leif

>
>
> Regards


Mime
View raw message