tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felipe Jaekel <fkjae...@gmail.com>
Subject Re: 404 on web services when webapp is deployed as ROOT.war
Date Wed, 13 Sep 2017 13:56:26 GMT
Hi Romain,

I tried 7.0.3 and got the same result. I forgot to mention that I also
change this line on system.properties:

openejb.wsAddress.format = /{ejbName}

2017-09-13 2:20 GMT-03:00 Romain Manni-Bucau <rmannibucau@gmail.com>:

> Hi Felipe
>
> Can you try with tomee 7.0.3?
>
>
>
>
>
> Le 12 sept. 2017 22:51, "Felipe Jaekel" <fkjaekel@gmail.com> a écrit :
>
> Hi,
>
> I have several TomEE 7.0.2 plus instances on production running a single
> webapp each, so I deploy it as ROOT.war (parallel deployment). I have
> implemented some web services, but when I try to access them I get a 404
> error. If I deploy the webapp with a different name from ROOT I'm able to
> access these web services(also using parallel deployment).
>
> Changes I made on system.properties:
>
> tomee.jaxws.subcontext = ws
>
> openejb.deploymentId.format = {appId}/{ejbJarId}/{ejbName}
> openejb.jndiname.format = {deploymentId}{interfaceType.annotationName}
>
>
> I noticed this on the log:
>
> 12-Sep-2017 17:29:13.663 WARNING [localhost-startStop-1]
> org.apache.catalina.core.StandardContext.setPath A context path must
> either
> be an empty string or start with a '/' and do not end with a '/'. The path
> [/] does not meet these criteria and has been changed to []
>
>
> Do I need additional config?
>
> Thanks
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message