tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Blazart <yann.blaz...@bycode.fr>
Subject Re: Tomee (plus/plume) 1.7.1 : Already a destination Bug
Date Fri, 21 Nov 2014 13:54:54 GMT
Same...

I use  :
           <plugin>
                <groupId>org.apache.openejb.maven</groupId>
                <artifactId>tomee-maven-plugin</artifactId>
                <version>1.7.1</version>
                <configuration>
                    <tomeeVersion>1.7.2-SNAPSHOT</tomeeVersion>
                    <tomeeClassifier>plus</tomeeClassifier>

...

I can see INFOS: Starting Servlet Engine: Apache Tomcat (TomEE)/7.0.56
(1.7.2-SNAPSHOT) in logs

But when I do reload :

nov. 21, 2014 2:54:04 PM org.apache.openejb.server.webservices.WsService
deployApp
GRAVE: Error deploying JAX-WS Web Service for EJB
chaton-serv2/chaton-serv2-web/UploaderService
java.lang.RuntimeException: Already a destination on
http://UploaderService:80
at
org.apache.cxf.transport.http.DestinationRegistryImpl.addDestination(DestinationRegistryImpl.java:49)

2014-11-21 14:29 GMT+01:00 Romain Manni-Bucau <rmannibucau@gmail.com>:

> Hi
>
> not sure it was fixed or not but in all cases 1.7.2-SNAPSHOT doesn't
> have this issue (at least not exactly the same) since it doesn't use
> this destination anymore
>
>
> Romain Manni-Bucau
> @rmannibucau
> http://www.tomitribe.com
> http://rmannibucau.wordpress.com
> https://github.com/rmannibucau
>
>
> 2014-11-21 14:10 GMT+01:00 Yann Blazart <yann.blazart@bycode.fr>:
> > Hi !
> >
> > I'm facing to a reload bug while developping on TomEE.
> >
> > I'm using the tomee maven plugin.
> > My application is packaged in an EAR (I have to deal with it).
> > The webservice is an EJB  packaged in a jar. This jar is included in the
> > WEB-INF/lib
> >
> > The first load is ok.
> >
> > INFO: Webservice(wsdl=
> >
> http://localhost:8080/chaton-serv2-web/webservices/chaton-serv2/chaton-serv2-web/UploaderService
> ,
> > qname={http://ws.services.serv2.chaton.tomee.poc.bpi.fr/}UploaderWS) -->
> > Ejb(id=chaton-serv2/chaton-serv2-web/UploaderService)
> > nov. 21, 2014 1:22:04 PM org.apache.openejb.server.webservices.WsService
> > deployApp
> > INFO: Webservice(wsdl=
> >
> http://localhost:8080/chaton-serv2-web/webservices/chaton-serv2/chaton-serv2-web/MyEntityService
> ,
> > qname={http://ws.services.serv2.chaton.tomee.poc.bpi.fr/}MyEntityWS) -->
> > Ejb(id=chaton-serv2/chaton-serv2-web/MyEntityService)
> >
> >
> >  But when I change some code (I(m using the sync parts of the plugin to
> > reload the app), or simply I put enter and use the reload commande, I'm
> > facing to the following error :
> >
> >
> > SEVERE: Error deploying JAX-WS Web Service for EJB
> > chaton-serv2/chaton-serv2-web/UploaderService
> > java.lang.RuntimeException: Already a destination on
> > http://UploaderService:80
> >
> > this is really annoying.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message