tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scratch <craigmical...@yahoo.com>
Subject TomEE Plus (1.0.0-beta-2): Getting NPE for JAX-RS resource with context root "/"
Date Fri, 13 Jan 2012 13:51:43 GMT
Hi guys,

First off, great work. I love the idea of being able to deploy EE 6 apps
within a Tomcat environment.

I've run into a problem with my JAX-RS resources. When I set my app's
context root to something like "/myapp", it works fine; but when my app is
run in the root context (ROOT.war), I'm seeing this:

Caused by: java.lang.NullPointerException
	at
org.apache.tomee.webservices.TomcatRsRegistry.createRsHttpListener(TomcatRsRegistry.java:92)
	at
org.apache.openejb.server.rest.RESTService.deployPojo(RESTService.java:237)
	at
org.apache.openejb.server.rest.RESTService.afterApplicationCreated(RESTService.java:111)
	at
org.apache.tomee.webservices.TomeeJaxRsService.afterApplicationCreated(TomeeJaxRsService.java:55)
	at
org.apache.tomee.catalina.WebDeploymentListeners.afterApplicationCreated(WebDeploymentListeners.java:38)


I've stepped through the code, and it looks like createRsHttpListener() is
assuming that the webContext is always non-blank. 

For now, I can just workaround this by deploying to a non-root context, but
I just wanted to see if this was a known problem.

Thanks!


--
View this message in context: http://openejb.979440.n4.nabble.com/TomEE-Plus-1-0-0-beta-2-Getting-NPE-for-JAX-RS-resource-with-context-root-tp4292186p4292186.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message