tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Wiesner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-2260) TomEE should support library asm7 (xbean 4.11 or higher) to support fully Java 11
Date Mon, 12 Nov 2018 10:46:00 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-2260?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16683551#comment-16683551
] 

Martin Wiesner commented on TOMEE-2260:
---------------------------------------

Could you also check whether this issue affects TomEE 7.0.x?
 * If _true_: please updated +Affects Version/s+ field in the details section above.
 * _else_: please comment so others know that backports to still maintained versions (see
above) are not needed.

Personal view:
I think this might also affect the upcoming 7.0.6, as there are still many production systems
around that rely on 7.0.5+. Some systems are being upgraded to Ubuntu 18.04 LTS in which Java11
will be a LTS version.

> TomEE should support library asm7 (xbean 4.11 or higher) to support fully Java 11
> ---------------------------------------------------------------------------------
>
>                 Key: TOMEE-2260
>                 URL: https://issues.apache.org/jira/browse/TOMEE-2260
>             Project: TomEE
>          Issue Type: Dependency upgrade
>          Components: TomEE Core Server
>    Affects Versions: 8.0.0-M1, 7.1.0
>         Environment: Java 11
>            Reporter: Artur Linhart
>            Priority: Major
>
> Because the TomEE server uses for the analysis of the deployed classes the asm library,
there should be included the library asm7, which does officially support all of the features
from java 11. It is especially important because Java 11 is the LTS Version from Oracle, so
very much suitable for the development of production stable applications. Todays asm6 library
used in versions 7.1.0 and 8.0.0-M1 does not support java 11 officially and fully, asm6 in
versions 6.2 and 6.2.1 (in xbeans 4.9 and 4.10) supports java 11 only in experimental way.
See
> [https://asm.ow2.io/versions.html]
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message