tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Murphy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-2182) Arquillian Test Causes java.lang.IncompatibleClassChangeError
Date Mon, 26 Mar 2018 11:30:00 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-2182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16413706#comment-16413706
] 

Gary Murphy commented on TOMEE-2182:
------------------------------------

Thank you for that quick response.  That resolved the problem.

> Arquillian Test Causes java.lang.IncompatibleClassChangeError
> -------------------------------------------------------------
>
>                 Key: TOMEE-2182
>                 URL: https://issues.apache.org/jira/browse/TOMEE-2182
>             Project: TomEE
>          Issue Type: Bug
>          Components: TomEE Arquillian Adapters
>    Affects Versions: 7.0.4
>            Reporter: Gary Murphy
>            Priority: Major
>
> I am trying to create a very simple Arquillian test for EJBs using embedded TomEE. 
I get the following when I try to run the test:
> Caused by: java.lang.IncompatibleClassChangeError: Class org.apache.webbeans.conversation.ConversationStorageBean
does not implement the requested interface javax.enterprise.inject.spi.BeanAttributes
> I found an item on the forum to exclude cdi-api, which I attempted to do, but that did
not resolve the issue.
> The code can be found on GitHub at:
> https://github.com/hilbertglm/arquillian-example.git
> I suspect it is an issue with versions or POM setup, but I am stuck at this point.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message