tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romain Manni-Bucau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENEJB-1847) When deploying two ear files in openejb only the first one gets deployed correctly
Date Tue, 26 Jun 2012 19:39:44 GMT

    [ https://issues.apache.org/jira/browse/OPENEJB-1847?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13401637#comment-13401637
] 

Romain Manni-Bucau commented on OPENEJB-1847:
---------------------------------------------

I used tomee snapshot.

well the point was did you define twice the same bean (maybe ignoring it-
                
> When deploying two ear files in openejb only the first one gets deployed correctly
> ----------------------------------------------------------------------------------
>
>                 Key: OPENEJB-1847
>                 URL: https://issues.apache.org/jira/browse/OPENEJB-1847
>             Project: OpenEJB
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 4.0.0
>            Reporter: Marcel Urbanek
>         Attachments: TestEJB3EA.ear, aTestEJBAnnotaitionEA.ear
>
>
> I deployed two ear files in open ejb by copying them to the "apps" directory. 
> While each of the ear files is deployed correctly when deployed alone, when deploying
them together open ejb will correctly find the ejbs in the second ear (log:"Auto-deploying
ejb"), but it fails to register them in the jndi (log:"INFO: Jndi(name=...) --> Ejb(deployment-id=...)"
is missing).
> I can reproduce this behaviour with any two ear files, even the most trivial ones.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message