tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Neeley <sean.nee...@producepro.com>
Subject Re: Having trouble with tomcat 7 installation on RHEL 7.8 power pc
Date Wed, 01 Jul 2020 17:15:58 GMT
Permissions of /var/log/tomcat look fine:
drwxrwx---.  2 tomcat root     4096 Jul  1 08:34 tomcat

And it is creating the logs, they are just empty:
-rw-r--r--   1 tomcat tomcat    0 Jul  1 08:34 catalina.2020-07-01.log
-rw-r--r--   1 tomcat tomcat    0 Jul  1 08:34 host-manager.2020-07-01.log
-rw-r--r--   1 tomcat tomcat    0 Jul  1 08:34 localhost.2020-07-01.log
-rw-r--r--   1 tomcat tomcat    0 Jul  1 08:34 manager.2020-07-01.log

/var/log/messages shows:
Jul  1 09:31:03 ecom-main systemd: Started Apache Tomcat Web Application
Container.
Jul  1 09:31:03 ecom-main server: Java virtual machine used:
/usr/lib/jvm/jre/bin/java
Jul  1 09:31:03 ecom-main server: classpath used:
/usr/share/tomcat/bin/bootstrap.jar:/usr/share/tomcat/bin/tomcat-juli.jar:/usr/share/java/commons-daemon.jar
Jul  1 09:31:03 ecom-main server: main class used:
org.apache.catalina.startup.Bootstrap
Jul  1 09:31:03 ecom-main server: flags used:
Jul  1 09:31:03 ecom-main server: options used:
-Dcatalina.base=/usr/share/tomcat -Dcatalina.home=/usr/share/tomcat
-Djava.endorsed.dirs= -Djava.io.tmpdir=/var/cache/tomcat/temp
-Djava.util.logging.config.file=/usr/share/tomcat/conf/logging.properties
-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
Jul  1 09:31:03 ecom-main server: arguments used: start


On Wed, Jul 1, 2020 at 12:00 PM calder <calder.cay@gmail.com> wrote:

> On Wed, Jul 1, 2020, 11:15 Sean Neeley <sean.neeley@producepro.com> wrote:
>
> > I just installed tomcat 7 on a Red Hat Enterprise Linux Server 7.8, power
> > pc system.  As soon as the service starts, the java process uses 100%
> cpu.
> > Logs get created in /var/log/tomcat, but they all have size 0 bytes.  I
> > have not modified the standard configuration (tomcat.conf, server.xml,
> > etc).  The tomcat packages that are installed are:
> >
> > tomcat-7.0.76-12.el7_8.noarch
> > tomcat-jsp-2.2-api-7.0.76-12.el7_8.noarch
> > tomcat-el-2.2-api-7.0.76-12.el7_8.noarch
> > tomcat-lib-7.0.76-12.el7_8.noarch
> > tomcat-servlet-3.0-api-7.0.76-12.el7_8.noarch
> >
> > Are there any tricks I can use to troubleshoot what is going wrong?
>
>
> Check "syslog" for clues.
>
> Also, double-check the permissions for  /var/log/tomcat.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message