tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "M. Manna" <manme...@gmail.com>
Subject Re: tomcat thread incurring CPU load
Date Wed, 13 Nov 2019 17:55:27 GMT
Hi Chris,

On Wed, 13 Nov 2019 at 16:27, Christopher Schultz <
chris@christopherschultz.net> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> On 11/13/19 11:20, M. Manna wrote:
> > HI Mark,
> >
> > On Wed, 13 Nov 2019 at 15:38, Mark Thomas <markt@apache.org>
> > wrote:
> >
> >> On 12/11/2019 19:11, M. Manna wrote:
> >>> HI Mark,
> >>>
> >>> following my previous reply, we have now confirmed that it's
> >>> indeed
> >> 8.5.45
> >>> with APR 1.2.23 that's causing such high JVM CPU usage. We used
> >>> took out 2 out of 50 servers from the load balancer config,
> >>> reverted tomcat, and redeployed. With near to identical user
> >>> traffic, the two servers are responding normally
> >>> without/without traffic with 8.5.41. The JVM dump looks a lot
> >>> better with 8.5.41.
> >>>
> >>> We do think that the recent changes in APR and some other
> >>> tomcat jar may have caused compatibility issue on Windows
> >>> server 2016 (64-bit) platform. But unfortunately, we cannot
> >>> pinpoint exactly what change may have caused this (i.e. actual
> >>> OS vs Security Updates). With this in mind, we are also being
> >>> wary to move to 8.5.47 as we don't know if the same issue will
> >> occur
> >>> again. Since 8.5.41 has been packaged with previously accepted
> >> application
> >>> installer, we are more comfortable rolling back.
> >>
> >> Just to confirm, you see this high CPU usage with a clean install
> >> (no additional web applications deployed, no configuration
> >> changes) on Windows 2016 DataCenter (64-bit)?
> >>
> >> If this is the case, it should be fairly easy to reproduce.
> >>
> >> Mark
> >>
> >> We do not deploy multiple applications. In fact, Under tomcat
> > webapps/ROOT we only have one application (ours). Each tomcat
> > instance is hosted on a VM (total 50) and all of them are
> > identically configured (server.xml, web.xml, logging, CPU/RAM). We
> > have not made any other configuration change between 8.5.41 and
> > 8.5.45. And yes, I agree with you that it's fairly easy to
> > reproduce.
>
> I think the question is whether or not your application is required to
> be deployed. Can you reproduce this issue with just the stock
> applications bundled with Tomcat?
>

My apologies, but our application needs to be deployed. We have not (or
didn't try in the past) to simply deploy tomcat with stock application (in
other words, simply starting the tomcat OOB) on our prod servers.
This is the first time it has hit us with such disparity. I’ll try to
investigate and get a stock application data. But we may not be able to do
that quite easily as it’s in our production.

What I can see is that 3 Windows updates may have been responsible for
this, but we aren’t sure about that. I’ll let you know if we can get
anything with the stock application instance.

Thanks,

- -chris

> -----BEGIN PGP SIGNATURE-----
> Comment: Using GnuPG with Thunderbird - https://www.enigmail.net/
>
> iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAl3MLscACgkQHPApP6U8
> pFip5A/+KOg4ZvATDli8zG9ZxniMoPdkOC9LQgVKscjeLZHL/A1gzVLP8UPZSiU7
> 1+p44WwJ5WGgwe8Ne0NZTFlh7/DZQAGIQZv++Ii9+NRkY5KVP3dYykdoyg1UdUMB
> Fdu2KNDcsCERYpPqrE/kVk+TQZNI60vY8iTBntc+Og5LsukULZTbX3UO9BzDaqeO
> WsjVuP6q7hUDBntd+5YqeFKDJ07zEIm5V6vmHAbCOWm3g2B8IXiYkMTXM+ZLld9h
> 6Th8f+na79taUrxT9TwI1WoR/ZJguJW1c8eRPbykv9/riDrtTQsv0BZy0ZeMhnjv
> kEwurNMaYjtSSCGOD0e8/chy1rU0/gng99pkmGe0Wiwoob6/6AU0HhE/2RvLKzDY
> mR4hu+aDaxtog4CD9DQrGenId+pwbJteqhXVCye6V0A3JtobbR+D56cxcUbth1pP
> skMdXrTWTvVlmsyLfKjPmMiALzOqg0bqvfYH5bEitW1Y8HvCQN5vcht2+EOpchmp
> zZ0f0LQpXEyr3DJ/GSbPTRKHghMAnrB4yz9jlMvzdWoPX2/JyT3+IQOoe8eRtlD8
> e6uoQzXoguXFr9J5OLGR5TXdBLx5/obCUWUM2wS/w5TQ3MvV3C5haSKYWTVIcetp
> XuAzKmK6fKFBHn37pMLd4VELy9Ay+zQmtTrpDJzB9pPwX/gr6JQ=
> =VqkL
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message