tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat not responding (in browser) after undeploying docs and examples application.
Date Sun, 16 Jun 2019 10:05:06 GMT
вс, 16 июн. 2019 г. в 07:11, Nazmus Sadat <nazmus.cse@gmail.com>:
>
> Greetings.
> For security reasons, I wanted to remove docs and examples application. So,
> at first, I deleted both of their directories from the webapps directory.
> However, the remaining applications (including manager app) were not
> responding in browser (blank pages were being served), although the tomcat
> service was running in the server. The logs were not showing anything.
>
> Then I put back docs and examples directories in webapps directory, and
> things were back again. Then, I tried to undeploy them using tomcat
> manager. The undeployment works, but again I got blank screens for
> remaining applications.
>
> I even tried restricting access to these two apps (docs and examples) using
> valve and filters. And unfortunately, again the same issue: I get blank
> screens.
>
> Finally, I started with a clean installation. However, I get same result
> after undeploying docs and examples.
>
> Permission is not an issue, all contents belong to the tomcat user.
>
> I am using Tomcat 8.5.37.
>
> Operating System: Amazon Linux 4.14.88
> Java version: 1.8.0_191-b12

1. What is in your access log file? (Was the request processed by Tomcat?)

(as mentioned in FAQ > Troubleshooting)

2. Blank page in Tomcat 8.5 may be generated for either of the following reasons
a) the request was rejected at an early stage of processing before
reaching a web application (e.g. an incorrect request, HTTP response
code 400)

b) there is no ROOT web application, i.e. there is no application that
has an ErrorReportValve that can generate an user-friendly error page.

> Finally, I started with a clean installation.

3. A clean installation starts with downloading a binary release (zip
or tar.gz file) from tomcat.apache.org we site. Is this what you did?

Why aren't you using the current version (8.5.42)?


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message