tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Tomcat 7 under Java 11? Re: Has anybody ever heard of "ECDHE-ECDSA-CHACHA20-POLY1305"?
Date Wed, 20 Mar 2019 21:53:22 GMT
On 20/03/2019 10:05, Mark Thomas wrote:
> On 19/03/2019 23:49, James H. H. Lampert wrote:
>> In response to my question:
>>
>>>> I've just (same customer as before) been asked about
>>>> ECDHE-ECDSA-CHACHA20-POLY1305 and ECDHE-RSA-CHACHA20-POLY1305
>>>>
>>>> and I can't find either one on the Sun or IBM JSSE cipher lists for
>>>> Java 8.
>>
>> On 3/19/19, 12:34 AM, Peter@Kreuser-Online wrote:
>>
>>> Most certainly only >=Java9... (OpenJDK and Oracle, don’t know about
>>> IBM though)
>>
>> Thanks.
>>
>> I've since learned that IBM Midrange systems will skip 9 and 10, but
>> will offer Java 11 at some point. But that begs the question of whether
>> or not Tomcat 7 (or our webapp context) will even run under Java 11.
> 
> Tomcat 7 should run. If it doesn't, it would be treated as a bug and
> we'd fix it. We do test it from time to time.

This thread prompted me to grab the latest OpenJDKs and test them.

9.0.x and 8.5.x build and run with the latest Java 13 early access build
(EA12).

7.0.x won't build with Java 12 onwards because Tomcat 7 has a minimum
Java version of 6 and Java 11 was the last version of the compiler that
accepted Java 6 as an option. Once it is built, Tomcat 7.0.x runs quite
happily under Java 13 EA 12.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message