tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guang Chao <guang.chao.1...@gmail.com>
Subject Re: Connection refused: connect
Date Thu, 27 Sep 2018 03:50:20 GMT
On Fri, Sep 21, 2018 at 4:54 PM Karen Goh <karenworld@yahoo.com.invalid>
wrote:

> Hi,
>
> I am repeatedly getting the following exceptions and am stuck here like
> forever.
>
> Hope someone can tell me what's wrong with my tomcat server  version:
> 8.5.24 with Eclipse
>
>
> java.net.ConnectException: Connection refused: connect
>         at java.net.DualStackPlainSocketImpl.connect0(Native Method)
>         at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
>         at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
>         at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown
> Source)
>         at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
>         at java.net.PlainSocketImpl.connect(Unknown Source)
>         at java.net.SocksSocketImpl.connect(Unknown Source)
>         at java.net.Socket.connect(Unknown Source)
>         at java.net.Socket.connect(Unknown Source)
>         at java.net.Socket.<init>(Unknown Source)
>         at java.net.Socket.<init>(Unknown Source)
>         at
> org.eclipse.jdi.internal.connect.SocketTransportService$2.run(SocketTransportService.java:148)
>         at java.lang.Thread.run(Unknown Source)
>
> Tks.
>

Can I assume that what you are trying to do are the following?

- You downloaded Tomcat 8 and extracted somewhere on hard drive
- You created a web project in Eclipse
- You created new Server Runtime by adding in preferences and specifying
the path of your Tomcat 8
- You run your web project using the runtime



>
> --- On Sat, 9/15/18, Karen Goh <karenworld@yahoo.com> wrote:
>
> > From: Karen Goh <karenworld@yahoo.com>
> > Subject: Error: Could not find or load main class set
> > To: users@tomcat.apache.org
> > Date: Saturday, September 15, 2018, 2:50 PM
> > Hi,
> >
> > I am now getting the above error.
> > There is no further error stacktrace from error log or
> > console etc.
> >
> > So far, I have deleted the server and
> > created new instances but still getting the same error.
> >
> > I have read the following solutions but
> > they are not helpful
> >
> >
> http://www.java67.com/2016/09/3-ways-to-solve-eclipse-main-class-not-found-error-java.html
> >
> >
> https://www.researchgate.net/post/How_to_solve_Error_Could_not_find_or_load_main_class
> >
> > Please help.
> >
> > Tks,
> > Karen
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

-- 
Guang <http://javadevnotes.com/java-array-of-objects>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message