tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandels Mark (RTH) OUH" <Mark.Sand...@ouh.nhs.uk>
Subject RE: Apache http via tomcat WAR or Directory URL syntax (tomcat server.xml) for WAR application not working
Date Mon, 02 Jul 2018 08:42:21 GMT
Hi Chris

I started off looking at older documentation on how to configure tomcat and apache http as
a tomcat connector but have referred to tomcat connectors v 9 now. I have referred to the
correct version of the documentation for Apache http 2.4.

Can you see anything in my configuration which should be changed?

Mark

Mark Sandels |Senior Systems Analyst/Programmer|IM & T Services – Integration Services
Team |Manor House Annexe Room G22, Oxford University Hospitals NHS Trust , Headley Way, Headington,
Oxford OX3 9RR |Phone:  01865 (5) 72103 | Email: mark.sandels@ouh.nhs.uk NHS colleagues can
visit the OUH IM&T Services intranet site at http://ouhimt.oxnet.nhs.uk 

-----Original Message-----
From: Christopher Schultz [mailto:chris@christopherschultz.net] 
Sent: 29 June 2018 21:35
To: users@tomcat.apache.org
Subject: Re: Apache http via tomcat WAR or Directory URL syntax (tomcat server.xml) for WAR
application not working

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Mark,

On 6/29/18 3:32 AM, Sandels Mark (RTH) OUH wrote:
> Hi Andre
> 
> I am using Apache Tomcat connectors -
> 
> https://tomcat.apache.org/connectors-doc/webserver_howto/apache.html
>
>  I got confused about using http as a proxy.
> 
> Here is my workers.properties file:
> 
> Workers.tomcat_home=C:\Program Files (x86)\apache-tomcat-9.0.6
> #Make mod_jk module aware of Tomcat workers.java_home=C:\Program
> Files (x86)\Java\jre1.8.0_161 #Make mod_jk module aware of jre ps =
> \ # Specify the file path separator worker.list=ajp13 
> worker.ajp13.port=8009 #Workport , this port should match the port
> used by the AJP/1.3 protocol of the Connector element in server.xml
>  worker.ajp13.host=localhost #Tomcat server address 
> worker.ajp13.type=ajp13 #type

Uhh... the workers.properties file you sent yesterday was different.
Are you making changes?

If you are using tomcat_home and java_home directives, your
configuration looks to be ancient. Are you following a setup guide
from 2005?

- -chris
-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAls2l+QACgkQHPApP6U8
pFj5+A/7B12TLAhQWEiP0Po9XCeg7/gaVTtEHEbiJLp7lQ5Odq30+b4RGYIlvBUq
m2A3cNcezsk+9rwYGLUWPXti5Blv+TtvqmJWYQJ6fLyuSSSRcJbBKj5XmEeKRtim
RXRmwuCFWMILP1pEdDPDMXXM5BpqtyolmxECOfT+TeYwwArokA2DA55EXaPquDTk
1I7/29FwTAb2X/pOqXQjw6HrxuHswgTjr3pj6IQl9nKNRizlqtJ4AwbmdAHDbvB4
npoDXS51Is5A75D2kzSbKNMzgQYG/QriCVqoNYZNqOgd7X6isM3S5/Z2os+KrjAp
9SZB1LWbbfaYByPe2IzjPNJA/vpMFFIRiovjgKIxXLGqojrEhhfbIUVS3DHVjmps
2+Fdxt63TI+Z5bEqxMRGIPpEMre1GLIPu/r4Cd2l/lJeRCc+FShz6VhZgfIv5xdF
UmT0E2FX9unAlAbB2fxzZ5YG0Tmjv+yeNkydMGZ+fiieEp8pQPNmBIj5OBkrY9jE
RCNsdtUtYkcLiUXuDHnwdC7FwaI/LmtF3JdJwOr9hnIXSEfZLsvBPcLrsexBWNLj
kdHqZkvA/HOgKEoF6NfWEiEnBASVsSCxbdNf+u11YjlWfgbAHlNzkhUwPL+Gt3T5
8FsJBUsJsbTNmSIsc/+9aj4eY8P1s6pMNFkabj4AvtFihuCzUeg=
=/Old
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

Mime
View raw message