tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daryl Stultz <daryl.stu...@opentempo.com>
Subject Re: Manager app text mode refuses to deploy
Date Fri, 06 Apr 2018 18:36:07 GMT


> As per the docs[1], this only works for a previously-deployed
> application. Deploying a new application requires additional parameters.

It's not super clear in the docs, the section "Deploy a previously deployed webapp" is the
first item under the header "Deploy A New Application from a Local Path". We weren't doing
anything different from Tomcat 6 so it seems a fair misunderstanding.

> I think you actually want this:
> https://tomcat.apache.org/tomcat-8.5-doc/manager-howto.html#Deploy_a_Directory_or_War_from_the_Host_appBase

> No slashes necessary.

Yes, that's true, we are now staging to an intermediate directory and it seems to be happier
now. The slash was a misdirection, we had to double quote the full URL, I think wget was mangling
it.


> Tomcat crashes?

> Did you make this request once or twice?

I don't know, things might have been in a bad state prior to the undeploy attempt.

> Same application path? You've been using /my-app above, but probably in
> an attempt to anonymize your application. Always helps to double-check
> the speling.

Yeah, my-app was a cover for the real name das-qa-java8.


>Seems like it can't find the application.

> I'm guessing something else is going wrong,

Probably true. After working out the correct manager app calls, cleaning out deploys and the
work directory everything seems to be working now. We'll see how stable it is.

Thanks for your help.

/Daryl

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message