tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Can you access my Manager App? http://24.0.5.14:8081/manager/html Tomcat/8.5.29, CentOS&Win10
Date Thu, 05 Apr 2018 14:54:30 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Philip,

On 4/5/18 12:37 AM, Philip Rego wrote:
> http://24.0.5.14:8081/manager/html

Reach? Yes. Login? No.

> *tomcat-users.xml*<xml version="1.0" encoding="UTF-8"?> 
> <tomcat-users xmlns="http://tomcat.apache.org/xml" 
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
> xsi:schemaLocation="http://tomcat.apache.org/xml tomcat-users.xsd" 
> version="1.0"> <role rolename="manager-gui"/> <user
> username="tomcat" password="s3cret" roles="manager-gui"/> <role
> rolename="tomcat"/> <role rolename="role1"/> <role
> rolename="manager-gui"/> <user username="hello" password="p4ssw0rd"
> roles="manager-gui"/> <user username="tomcat" password="p4ssw0rd" 
> roles="standard,manager-gui,tomcat,manager-script,manager-script"/>
>
> 
<role rolename="manager"/>
> <user username="admin" password="admin" roles="manager"/> 
> </tomcat-users>

I tried users "tomcat" and "hello". Your file looks okay to me.

> Why can't I log in? I get a 401 error when I try with any these
> users. Do I have them set correctly? The 401 error said I can get
> access by adding the user "tomcat" like I so. I also read the
> documentation 
> <http://24.0.5.14:8081/docs/manager-howto.html#Configuring_Manager_App
lication_Access>
>
> 
but
> I must not understand. I tried running tomcat on my windows
> computer and got a similar 403 error. I originally had this issue
> when I was trying to integrate my Spring Boot app in Jenkins and
> got error
> 
> org.codehaus.cargo.container.tomcat.internal.TomcatManagerException:
>
> 
The username and password you provided are not correct (error 401).
> 
> (I know it's not safe giving out passwords like this but there's 
> nothing on the machine I care about, and want to have the issue 
> resolved)

My guess is that one or more of the following is true:

1. The tomcat-users.xml file isn't in your CATALINA_BASE/conf/ directory

2. Your CATALINA_BASE/conf/server.xml does not have a <Resource> in it
for MemoryUserDatabaseFactory

3. Your Manager application doesn't have a <Realm> configured

Can you confirm all of the above?

- -chris
-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAlrGOKYACgkQHPApP6U8
pFh/RBAAq7PwPcwQ9HjBLne2qf5K1WJBO7gVSBUsJ9nVlkcgwnnlJhN4bI9tW69G
vuovsDZKuWPYNrh/1IqNjJ9DUxrO7bitO07AOJRpQcKsdtYeLx6k6xMdBj4bi/Vr
ysHm41pv6rT0YxAN3oBUaDWbG32CNIhKz6LOos1iKJ7/k4OH5KJsUy4pXDce2Rop
ybP7iuB8bmrx7TYHlKrtoNCUAQs0ah+0xlQ7kmrzgVKHhotKjukCmMLifaYZ823A
7HI4x/XF3xx202dSuUx7OMwBNlDcU8SOEt/cXsU1bRVUfeRK/tm1RVogoe2+hDZW
eIIpdnPnpsJaMp5FpBaS+VybHwjKfZyfY4rCl2q1lF3bRPDP6b9Xzu67+C6z0pnU
6LD4IKxIVMrPSwk3aTLcfrSvmUPla2nWV1Mp/KOl1QacQsBHW5LWA/Z+EAV6BaOU
foG+V7ICdEWri4G1x6uAlFgbfgQe+1nIfUpJ+8dpI0uW9wY56nMzKHF3Hj65KkBq
yOT00WxPLwhlNGre5dDLeoeN8i6ft9lxKvt+W1b58H9whySmhL2xULPIW9oPk1I2
Ua3Z17JkQSJKcX2EONW/T4vwGhhRFEXMmcge3tMWlpB4jch7CXJ5zFgUHzn2UB1R
NHLCtnxgTEJ2s6clckxuR+jMNl0+mktTcnGTUadpc6Cw0/hWvSg=
=3lRR
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message