tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Tomcat7 with jre 1.7 error during starting
Date Fri, 26 Jan 2018 13:38:35 GMT
Am 26.01.2018 um 12:08 schrieb Rajesh Cherukuri:
> HI
> 
> we have a existing  running tomcat version 5 running on solaris with out
> any issues ,  recently we have  installed tomcat 7 on the same solaris 10
> server  with no application deployed , and configured java version as
> jre1.6 in setenv.sh  i couldn't start the tomcats after my installation ,
> and below is the error what i get when i start tomcat with java1.7  later i
> tired the to configure the java version as 1.8 , i still get the same error
> but slightly different error but both are failing at "
> 
> *org.apache.catalina.util.ExtensionValidator.getManifest(ExtensionValidator.java:402)*
>      can some one let me know if there are any pre-requisites to run a
> tomcat on 7 on Soalris  10 ,

there should be no problem running a recent Tomcat 7 with an unchanged 
Oracle HotSpot Java 6, 7 or 8 on Solaris 10. I regularly do this.

Maybe you unpacked a downloaded tarball using Solaris tar? Solaris tar 
has a very specific way of handling long path names and is not 
compatible with gnu tar. Most tarballs noadays are packed using gnu tar 
and should be unpacked with gnu tar as well. Otherwise files can be 
missing or created with a wrong file name.

gnu tar for Solaris should be installed under /usr/sfw/bin/gtar.

Regards,

Rainer


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message