tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Peculiar problem (and solution) but WHY?
Date Mon, 06 Nov 2017 12:53:52 GMT
On 04/11/17 22:26, Ray Holme wrote:
> We have a working application running under tomcat 8.5.13
> I have been trying to reduce start up time and reduce TLD scanning which was taking too
long.
> By adding the jars in my .../WEB-INF/ lib to the NO scan line in the catalina.properties
file I got this under control ( a couple minutes went down to 1 second or less).
> However two libraries I use and added NEEDED to be removed from the exclusion list as
they caused (on MAC not on Linux where the application worked fine - 2nd weirdness) this problem:
> org.apache.jasper.JasperException: The absolute uri: http://java.sun.com/jsp/jstl/core cannot
be resolved in either web.xml or the jar files deployed with this application
> The above problem caused a page to show as a white screen (it would not work).
> 
> i.e. THE JARS NEED TO BE SCANNED (at least by the MAC Tomcat)
> 
> These jars were: jstl-api-1.2.jar and jstl-impl-1.2.jar
> 
> Can anyone explain this? It makes no sense to me and I would feel better if there was
a reason.

Those are tag libraries. The tag libraries need to be registered in
order to work. That is what the TLD (tag library descriptor) scan does.
If that scan is disabled, the TLDs aren't registered and the tag library
won't work.

As for the Mac vs Linux behaviour, I suspect different configurations.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message