tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernd Wahlen <bernd.wah...@k2interactive.de>
Subject Re: No traffic after upgrade to Tomcat 8.5.16 (loadbalancing issue)
Date Tue, 01 Aug 2017 09:43:12 GMT
Hi Peter and thanks for your help.

> From my perspective the Tomcat is working, responding and serving content.
>
> That leads to the thought, that the F5 is not evaluating the response correctly.
> In my opinion you should talk to the admins and ask them why they are not activating
your service.
> The Healthcheck of the F5 usually checks for certain data. 404 responses are strange
but may also work.
>
> The responses differ in size, so, there may be the problem (content and/or header differ!).
 The new response is larger, so it's not only missing the Server header!

The content size is different, but thats the default tomcat error 
message, e.g.

<!DOCTYPE html>
<html>
     <head>
         <title>Apache Tomcat/8.0.45 - Error report</title>
         <style type="text/css">H1 
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;}

H2 
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;}

H3 
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;}

BODY 
{font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} 
B 
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} 
P 
{font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A 
{color : black;}A.name {color : black;}.line {height: 1px; 
background-color: #525D76; border: none;}</style>
     </head>
     <body>
         <h1>HTTP Status 404 - /</h1>
         <div class="line"></div>
         <p>
             <b>type</b> Status report
         </p>
         <p>
             <b>message</b>
             <u>/</u>
         </p>
         <p>
             <b>description</b>
             <u>The requested resource is not available.</u>
         </p>
         <hr class="line">
         <h3>Apache Tomcat/8.0.45</h3>
     </body>
</html>

and changed a bit in 8.5, but there is definelty no check on the 
content, because i created a empty index.html, then the response is 
200/OK and content length is 0.
It is still working with 8.0 and not working with 8.5 again.

Many thanks in advance,

Bernd Wahlen
K2 Interactive GmbH

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message