tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Al Grant <bigal...@gmail.com>
Subject Debugging
Date Mon, 27 Feb 2017 01:33:52 GMT
Hello,

System: Windows 10
Tomcat Var: 8.5.4
IDE: Intellij Ultimate
Java: v1.8

I have started out creating war files. At the moment I am deploying by
copying the war to the webapps directory and then using chrome to browse
the URL.

I am compling the war in Intellij, but starting tomcat seperately from the
command line.

I need to start to debug.

I can connect the Intellij debugger to 8000 and I get some output that I
have connected ok:

Connected to server
Connected to target VM, address localhost:8000 etc

What is not clear to me is :

1. How would I use a breakpoint? Intelijlets me set one but this is not
honoured when I compile as war (in gradle)
2. Despite the servlet seeming doing the right thing (redirect) when I hit
a submit button the println statements do not appear to write anything to
either the CLI or the debugger.

Code snippet:

@Override
protected void doGet(HttpServletRequest request, HttpServletResponse response)
        throws ServletException, IOException {
    System.out.println("doGet hit");
    request.getRequestDispatcher("/index1.jsp").forward(request, response);
}

 ie - Index1.jsp gets loaded but the println statement doesnt seem to
appear anywhere.

Cheers

Al


-- 
"Beat it punk!"
- Clint Eastwood

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message