tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: JSP compilation fails with Java 9
Date Mon, 09 Jan 2017 14:24:40 GMT
2017-01-09 10:16 GMT+03:00 Patil, Shital <shitapatil@ptc.com>:
> We are assessing Java 9(early access) and JSP compilation is badly broken with Java 9.
Even basic java objects(java.lang.Object) are not accessible while compilation. Appears to
be because of jigsaw(modular)
>
> Any solution or alternative to this problem ?


1. Tomcat full version number =?

2. ecj.jar version (in Tomcat's lib directory) =?

3. Does it work with a later version of ecj.jar?  It is "JDT Core
Batch Compiler"
Downloadable from
http://download.eclipse.org/eclipse/downloads/
http://download.eclipse.org/eclipse/downloads/drops4/R-4.6.2-201611241400/

(Tomcat 8.5 ships with 4.5.1, Tomcat 9 uses 4.6.1,  latest release is
4.6.2,  but there is also a milestone build of 4.7 available)

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message