tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patil, Shital" <>
Subject RE: JSP compilation fails with Java 9
Date Tue, 10 Jan 2017 08:41:22 GMT
Tomcat 9.0.0.M15

With Java 9 build 146 JSP's are broken.
Surprisingly with Java 9 build 151, same tomcat started compiling and executing JSPs very
well :) 

Now that’s called sun chasers

-----Original Message-----
From: Rémy Maucherat [] 
Sent: 10 January 2017 04:56
To: Tomcat Users List <>
Subject: Re: JSP compilation fails with Java 9

2017-01-09 1:16 GMT-06:00 Patil, Shital <>:

> We are assessing Java 9(early access) and JSP compilation is badly 
> broken with Java 9. Even basic java objects(java.lang.Object) are not 
> accessible while compilation. Appears to be because of jigsaw(modular)
> Any solution or alternative to this problem ?
> I tested Java 9 relatively recently, and normally JSP compilation is 
> the
last remaining issue. I can confirm what was said: JDT doesn't have modules support, and it
doesn't have a planning for it from what I saw. There have been some significant updates to
the modules lately, so it would be unfair to blame the JDT people at this point.


-----Original Message-----
From: Mark Thomas [] 
Sent: 09 January 2017 17:40
To: Tomcat Users List <>
Subject: Re: JSP compilation fails with Java 9

As far as I am aware, the JDT compiler that Jasper uses by default does not yet support Java

You should be able to configure Jasper to use javac for Java 9.

From memory (I tested this some time ago), a basic JSP worked with Java 9. Whether more complex
JSPs might hit some Jigsaw related issues is TBD. Worst case, you should be able to work-around
them with command line options when starting Tomcat.

I've looked at Java 9 support a couple of times but partly because it is still in a state
of flux and partly because the JDT support was not there I haven't taken it very far.

From: Konstantin Kolinko [] 
Sent: 09 January 2017 19:55
To: Tomcat Users List <>
Subject: Re: JSP compilation fails with Java 9

1. Tomcat full version number =?

2. ecj.jar version (in Tomcat's lib directory) =?

3. Does it work with a later version of ecj.jar?  It is "JDT Core Batch Compiler"
Downloadable from

(Tomcat 8.5 ships with 4.5.1, Tomcat 9 uses 4.6.1,  latest release is 4.6.2,  but there is
also a milestone build of 4.7 available)

Best regards,
Konstantin Kolinko

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message