Hi,

Any pointers please?

Thanks,
Durga Srinivasu

On Wed, Dec 14, 2016 at 10:15 PM, Durga Srinivasu Karuturi <durgasrinivasu@gmail.com> wrote:
Hi,

Recent chrome [Mac - Sierra : Version 55.0.2883.87 (64-bit) ] we are seeing issues in http2 sites. Initially we have seen problem with http2 table header size limit error and to fix this, we have upgraded tomcat 8.5.4 to 8.5.9 where tomcat has increased the header limit from 16K to 64K. Now with latest tomcat 8.5.9 we are seeing ERR_SPDY_COMPRESSION_ERROR while loading dojo libraries.

Tried couple of steps (flush SPDY sokets etc) based on google search on this issue but nothing worked..


Inline image 1

t=10513 [st= 1]     -HTTP_TRANSACTION_SEND_REQUEST

t=10513 [st= 1]     +HTTP_TRANSACTION_READ_HEADERS  [dt=36]

t=10549 [st=37]        HTTP2_STREAM_ERROR

                       --> description = "ABANDONED (stream_id=139): https://10.104.118.174/webacs/lib/dijit/form/_ToggleButtonMixin.js.map"

                       --> status = -363

                       --> stream_id = 139

t=10549 [st=37]     -HTTP_TRANSACTION_READ_HEADERS

                     --> net_error = -363 (ERR_SPDY_COMPRESSION_ERROR)

t=10549 [st=37]   -URL_REQUEST_START_JOB

                   --> net_error = -363 (ERR_SPDY_COMPRESSION_ERROR)

t=10549 [st=37]    URL_REQUEST_DELEGATE  [dt=0]

t=10549 [st=37] -REQUEST_ALIVE

                 --> net_error = -363 (ERR_SPDY_COMPRESSION_ERROR)


Initial content is downloaded (other JS files etc) but on some dojo libraries alone, we are this issue which make application home page load fails. Firefox works! We are having latest tomcat 8.5.9 already. Not sure where else problem now. We have not enabled any compression server side.


https://bugs.chromium.org/p/chromium/issues/detail?id=673315 (Chrome bugs i have raised)

My guess is that the bug is in Tomcat, in that it does not send an HPACK dynamic table size update (so the dynamic table should be the default 4 kB) but uses a 64 kB dynamic table.
As soon as it references entries that are in fact already emitted, that's a compression error.
See https://www.ietf.org/mail-archive/web/httpbisa/current/msg27867.html for a discussion on how to interpret the specs.

According to the chrome bug notes problem is with tome dynamic table size 64k. I don't know how to confirm this is as tomcat issue as well. 

Can somebody help here to trace the problem?