tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier (tomcat) ...@ice-sa.com>
Subject Re: Tomcat 8 HTTPS issue with old browser
Date Tue, 04 Oct 2016 07:48:09 GMT
On 04.10.2016 09:38, Garratt, Dave wrote:
> I have Apache Tomcat 8 working ok with https when I connect to my web page using a recent
browser (desktop) or iPhone for example. However this specific application is designed to
run on a Motorola MC9090 hand held wireless barcode scanner running a relatively old version
of Windows Mobile. The browser on that device can only load the HTTP page and not the HTTPS
page, giving a unable to open page message. Speaking to a “expert” on these scanners the
consensus of opinion is that the type of encryption used by Apache Tomcat 8 is more up to
date than the mobile devices browser can support. As it does not appear likely that the mobile
devices are going to be updated any time soon I was wondering if its possible to force Tomcat
to accept deprecated protocols rather than be forced to revert to plain HTTP.
>
> Any ideas or ideally an example of how this might look in a config file would be most
appreciated.
>
>

Naive question : if you are dealing anyway with old devices that cannot be replaced by new

devices, then why do you not just keep using the correspondingly old version of tomcat and

of the JVM ?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message