tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier (tomcat) ...@ice-sa.com>
Subject Re: Set up postgresql on tomcat7
Date Wed, 17 Aug 2016 14:14:10 GMT
On 17.08.2016 16:06, Andrew Davis wrote:
> Thanks for the prompt..
>
> I have been looking at the doc s and have my .jar file for postgres in the
> lib folder.
>
> I do not understand where the <Context>
> <Resource name="jdbc/postgres..."
>
> Is supposed to go.
>
> Im reading at
> https://tomcat.apache.org/tomcat-6.0-doc/jndi-datasource-examples-howto.html

If your version is Tomcat 7, then maybe you should look at the Tomcat 7 documentation, not

the v 6 one.

In any case, even Tomcat 7 is somewhat old now.  Can you upgrade to a later version ? That

might increase your chances of getting help here.

>
> This author has not had success here...
>
> This doesn't inspire confidence  here,  but that's what the documentation
> shows...
>

Sorry, but personally my expertise in these matters is nil, so I hope someone else here 
can pick this up now.

> Andy
>
> On Aug 17, 2016 4:43 AM, "André Warnier (tomcat)" <aw@ice-sa.com> wrote:
>
> On 17.08.2016 11:32, Andrew Davis wrote:
>
>> Thanks.
>>
>> I can now deploy my servlets and they work ok, but..
>>
>> I had hoped to just deploy one copy of the postgres jar to my server and
>> then be able to consume it inside multiple applications, instead of having
>> multiple copies of the jar in multiple apps.
>>
>> I've been through the JNDI portion of the docs on Tomcat and found it still
>> somewhat confusing.
>>
>> Andy...
>>
>
> I am far from an expert on this kind of thing, but have you looked at this :
>
> http://tomcat.apache.org/tomcat-8.0-doc/config/globalresources.html
>
> Maybe that is the missing link in your understanding ?
>
>
>
>
>> On Aug 17, 2016 4:06 AM, "André Warnier (tomcat)" <aw@ice-sa.com> wrote:
>>
>> Andrew,
>>> this list strips most kinds of attachments, so nobody saw your screenshots
>>> or whatever was in them.
>>> You need to copy/paste that text right into your message to the list (amd
>>> make sure that you send your message as "plain text", not HTML, otherwise
>>> it will be unreadable.
>>>
>>> On 17.08.2016 02:10, Andrew Davis wrote:
>>>
>>> Well,
>>>> This has not turned out how I wanted it to .
>>>>
>>>> I have 'a solution' but it isnt what I wanted to do.  I went back and re
>>>> added the .jar file to the 'WEB-INF' folder and then deployed a new WAR
>>>> file.
>>>>
>>>> Now things work just 'fine' BUT I suspect that this is not what a real
>>>> coder would do and suspect I am still in the realms of hackery..
>>>>
>>>> [image: Inline image 1]
>>>>
>>>> Andy.
>>>>
>>>>
>>>>
>>>> On Tue, Aug 16, 2016 at 6:53 PM, Andrew Davis <drsockmonkee@gmail.com>
>>>> wrote:
>>>>
>>>> I found the following in my logs..
>>>>
>>>>>
>>>>> from command line in Putty...
>>>>>
>>>>> cd /var/lib/tomcat7
>>>>> tail -f logs/catalina.out
>>>>>
>>>>> [image: Inline image 1]
>>>>>
>>>>> I do have the jar file located in the following location on the
>>>>> machine..
>>>>>
>>>>> /usr/share/tomcat7/lib
>>>>>
>>>>> https://tomcat.apache.org/tomcat-7.0-doc/jndi-resources-howt
>>>>> o.html#JDBC_Data_Sources  is confusing to me.  It shouldnt but it is..
>>>>> at
>>>>> this point..
>>>>>
>>>>> Andy..
>>>>>
>>>>>
>>>>>
>>>>> On Tue, Aug 16, 2016 at 3:01 PM, George Sexton <georges@mhsoftware.com>
>>>>> wrote:
>>>>>
>>>>> The best place to start would be to look at tomcat's logs for exceptions
>>>>>
>>>>>> or errors.
>>>>>>
>>>>>>
>>>>>>
>>>>>> On 8/16/2016 12:44 PM, Andrew Davis wrote:
>>>>>>
>>>>>> Hello,
>>>>>>
>>>>>>> Im working on getting java servlets to run on my instance of
Ububtu
>>>>>>> with
>>>>>>> tomcat7.
>>>>>>>
>>>>>>> I write my applications in Eclipse.. when i run my apps localhost
i
>>>>>>> see
>>>>>>> everything just fine.
>>>>>>>
>>>>>>> When i export my WAR files i check the includ source files.
>>>>>>>
>>>>>>> I deploy the WAR file through tomcat manager.
>>>>>>>
>>>>>>> I can see the java classes which i use to insert records into
my
>>>>>>> postgresql
>>>>>>> database. However,  there is nothing happening.  When i attempt
 to
>>>>>>> run
>>>>>>> them, no joy.
>>>>>>>
>>>>>>> I have the postgresql .jar file installed on my headless ubuntu
server
>>>>>>> ,
>>>>>>> but no luck.
>>>>>>>
>>>>>>> Aside from the .jar file is there anything else i need to configure?
>>>>>>>
>>>>>>> Any advice is welcome
>>>>>>>
>>>>>>> Andy
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>>
>>>>>> George Sexton
>>>>>> *MH Software, Inc.*
>>>>>> Voice: 303 438 9585
>>>>>> http://www.connectdaily.com
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message