tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew M <bluemind2...@yahoo.com.INVALID>
Subject Re: Unable to access Manager App, Host Manager and Server Status urls
Date Sun, 14 Aug 2016 14:00:04 GMT
Tried that but no charm as of yet.
[root@docker1 META-INF]# cat /opt/tomcat/webapps/manager/META-INF/context.xml <?xml version="1.0"
encoding="UTF-8"?><!--  Licensed to the Apache Software Foundation (ASF) under one
or more  contributor license agreements.  See the NOTICE file distributed with  this work
for additional information regarding copyright ownership.  The ASF licenses this file to
You under the Apache License, Version 2.0  (the "License"); you may not use this file except
in compliance with  the License.  You may obtain a copy of the License at
      http://www.apache.org/licenses/LICENSE-2.0
  Unless required by applicable law or agreed to in writing, software  distributed under
the License is distributed on an "AS IS" BASIS,  WITHOUT WARRANTIES OR CONDITIONS OF ANY
KIND, either express or implied.  See the License for the specific language governing permissions
and  limitations under the License.--><!--<Context antiResourceLocking="false" privileged="true"
>  <Valve className="org.apache.catalina.valves.RemoteAddrValve"         allow="127\.\d+\.\d+\.\d+|::1|0:0:0:0:0:0:0:1"
/></Context>-->
If I add comments like the one I have bold, I am unable to access tomcat manager.So I have
to uncomment it.

After uncomment. It says access denied...

 

    On Sunday, 14 August 2016, 23:14, Mark Thomas <markt@apache.org> wrote:
 

 On 14 August 2016 12:37:37 BST, Andrew M <bluemind2005@yahoo.com.INVALID> wrote:
>I have clear the history, tried different browsers, restarted tomcat
>several times. I'm not sure what you want me to comment/uncomment. My
>context.xml file is below:

That is the global context.xml. Check the web application specific context.xml at $CATALINA_BASE/webapps/manager/META-INF/context.xml

Mark


>root@docker1 conf]# cat context.xml <?xml version="1.0"
>encoding="UTF-8"?><!--  Licensed to the Apache Software Foundation
>(ASF) under one or more  contributor license agreements.  See the
>NOTICE file distributed with  this work for additional information
>regarding copyright ownership.  The ASF licenses this file to You under
>the Apache License, Version 2.0  (the "License"); you may not use this
>file except in compliance with  the License.  You may obtain a copy of
>the License at
>      http://www.apache.org/licenses/LICENSE-2.0
>  Unless required by applicable law or agreed to in writing, software 
>distributed under the License is distributed on an "AS IS" BASIS, 
>WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
>implied.  See the License for the specific language governing
>permissions and  limitations under the License.--><!-- The contents of
>this file will be loaded for each web application --><Context>
>    <!-- Default set of monitored resources. If one of these changes,
>the    -->    <!-- web application will be reloaded.                
 
>                -->   
><WatchedResource>WEB-INF/web.xml</WatchedResource>   
><WatchedResource>${catalina.base}/conf/web.xml</WatchedResource>
>    <!-- Uncomment this to disable session persistence across Tomcat
>restarts -->    <!--    <Manager pathname="" />   
>--></Context>[root@docker1 conf]#  
>Spent lot of investigating but I'm still not sure what is the
>problem.....
>
>On Sunday, 14 August 2016, 19:55, Mark Olsson <safepassing2@gmail.com>
>wrote:
> 
>
>On Sun, Aug 14, 2016 at 1:43 AM, Andrew M
><bluemind2005@yahoo.com.invalid>
>wrote:
>
>> I tried disabling SE Linux but no charm :(
>> What is interesting is I have enabled finest level of debugging but I
>> cannot see anything in log files as ALL or finest level of logging.
>>
>
>Make sure if you have an address filter in
>webapps/manager/META-INF/context.xml that it's correct, and try
>removing or
>commenting it out temporarily even if it does look correct just in
>case.
>
>Since your first message was 18 hours ago, I'm assuming at some point
>you
>have closed and reopened your browser?  On my systems, if I enter the
>wrong
>user or password to get into the management console I get the 403 and I
>can't get back to the login prompt without completely closing and
>restarting the browser.  I don't know if that's intentional or just a
>side
>effect of Firefox and the various privacy extensions I use, never
>bothered
>to look for the cause.  So, depending on your browser, try
>closing/restarting, clearing caches and active logins, even try from a
>different browser.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message