tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Kelm <bk...@willamette.edu>
Subject Tomcat 7 and SSL...
Date Thu, 04 Feb 2016 17:52:24 GMT
  Not sure if anyone has seen this before, whenever we go to configure the
SSL connector and set the connector port to 8443, on tomcat startup they
are getting rewritten to another random port.

So we will have:

<Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               URIEncoding="UTF-8"
               redirectPort="8443" />

   <Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
               maxThreads="150" SSLEnabled="true" scheme="https"
secure="true"
               keystoreFile="/etc/tomcat7/keystore" keystorePass="xxxxx"
               clientAuth="false" sslProtocol="TLS" />


and I end up with this in the server.xml file on startup:

 <Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               URIEncoding="UTF-8"
               redirectPort="13043" />

   <Connector port="13043"
protocol="org.apache.coyote.http11.Http11Protocol"
               maxThreads="150" SSLEnabled="true" scheme="https"
secure="true"
               keystoreFile="/etc/tomcat7/keystore" keystorePass="xxxxx"
               clientAuth="false" sslProtocol="TLS" />


​Thanks for any thoughts.

Bill K.​


-- 
Bill G. Kelm - Systems Librarian
Willamette University Library
900 State Street - Salem, OR 97301
Phone: 503-375-5332   Fax: 503-370-6141

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message