tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McDermott, Becky" <bmcd...@sandia.gov>
Subject RE: [EXTERNAL] Re: Problem starting Tomcat 7.0.59 as a Windows Service
Date Tue, 12 Jan 2016 16:04:31 GMT
I used the Java options provided by IBM.  Since Tomcat will successfully start using the startup
batch files, I assume that these settings are fine.  I've tried playing with the settings
and cannot get it to work either.  I seems like it's some sort of weird Windows thing.

I have successfully configured these services before with prior version of IBM's CLM.  The
difference in those previous versions was that Tomcat came bundled with t heir product.  For
this latest IBM version, Tomcat was not bundled and they provided instructions for downloading
it from Apache and instructions for where to install it.

I have escalated the issue with IBM's support and since they are providing the JVM, it is
probably their issue but wanted to put it out to the larger community to see if anyone has
ever had this issue before.  A user on the user forums said that the memory error in the Tomcat
log file is a red herring and that it is giving that memory allocation error because the JVM
didn't actually start.  So, the issue seems more connected to the error in the Windows Event
viewer ("cannot open file").

-----Original Message-----
From: Christopher Schultz [mailto:chris@christopherschultz.net] 
Sent: Tuesday, January 12, 2016 8:59 AM
To: Tomcat Users List
Subject: [EXTERNAL] Re: Problem starting Tomcat 7.0.59 as a Windows Service

Becky,

On 1/12/16 10:42 AM, McDermott, Becky wrote:
> I am integrating Tomcat with the IBM CLM 6.0.1 collaboration tools.  Per IBM's installation
instructions, I downloaded and extracted Tomcat 7.0.59 to my server.
> 
> I am successfully able to start the Tomcat server from the command line using the batch
files provided by the IBM application (C:\Program Files\IBM\JazzTeamServer_601\server\server.startup.bat).
 Tomcat starts as well as all of the IBM CLM applications.
> 
> The problem I'm having is when I try to configure tomcat to run as a Windows service.
 I have followed the instructions provided by IBM:
> 
> 
> 1.       Set the environment variable CATALINA_HOME to C:\Program Files\IBM\JazzTeamServer_601\server\tomcat
> 
> 2.       Deleted existing tomcat7 services using:  sc delete tomcat7
> 
> 3.       Re-booted the machine

Note that, depending upon how you set the CATALINA_HOME environment variable, rebooting will
lose this value. I'm not sure the reboot was necessary.

> 4.       Installed the new tomcat service from the Tomcat bin directory:  service.bat
install tomcat7
> 
> 5.       Configured the service using:  tomcat7w.exe
> 
> 1.       Clicked "Java" tab
> 
> 2.       Cleared "Use default" checkbox
> 
> 3.       Added the following path to the Java Virtual machine:  C:\Program Files\IBM\JazzTeamServer_601\server\jre\bin\j9vm\jvm.dll
> 
> 4.       Added the following lines to the end of the java Options text field:
> -DJAZZ_HOME=file:///C:/PROGRA~1/IBM/JazzTeamServer_601/server/conf
> -Djava.awt.headless=true
> -Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=tr
> ue -Dcom.ibm.team.repository.tempDir=C:\Program 
> Files\IBM\JazzTeamServer_601\server\tomcat\temp
> -Djazz.connector.sslEnabledProtocols=TLSv1.2
> -Djazz.connector.algorithm=IbmX509
> -Dlog4j.configuration=file:///C:/PROGRA~1/IBM/JazzTeamServer_601/serve
> r/conf/startup_log4j.properties
> -Xgcpolicy:gencon
> -Xcompressedrefs
> -Xgc:preferredHeapBase=0x100000000
> -XX:MaxDirectMemorySize=1G

That's a BIG buffer. Do you need 1G NIO buffers? A web-based video-editing application?

> -Xmx4G
> -Xms4G
> -Xmn1g

What is -Xmn? It's probably not a problem, but I thought I'd point-out something that looks
weird.

> -DORACLE_JDBC_DRIVER_FILE=C:\Program 
> Files\IBM\JazzTeamServer_601\server\Oracle\ojdb6.jar
> 
> 5.       Cleared the following fields:
> 
> *         Initial memory pool
> 
> *         Maximum memory pool
> 
> *         Thread stack size
> 
> 6.       In the Startup and Shutdown tabs, confirmed that "jvm" was selected for the
"Mode" setting
> 
> When I try to start the service from Windows Services, I receive the following error:
> 
> Services
> Windows could not start the Apache Tomcat 7.0 tomcat7 on Local Computer.  For more information,
review the System Event Log.  If this is a non-Microsoft service, contact the service vendor
and refer to service-specific error code 4.
> 
> When I look at the Windows Event Viewer, there is an error that corresponds to the time
I tried to start the service:
> 
> The Apache Tomcat 7.0 tomcat7 service terminated with the following service-specific
error:
> The system cannot open the file.
> 
> The tomcat log file:  tomcat7-stderr.2016-01-12.log contains:
> 2016-01-12 08:35:10 Commons Daemon procrun stderr initialized 
> JVMJ9VM015W Initialization error for library j9gc27(2): Failed to 
> instantiate heap; 4G requested
> 
> I have contacted IBM support but they have not provided me a solution at this point.
 I thought I would submit here to see if it could be a Tomcat service issue specific to Windows.
 Here is my host information:
> Windows Server 2012 Standard
> Processor:  Siz-Core AMD Opteron(tm) Processor 8431 2.41 GHz Installed 
> Memory (RAM):  10.0 GB System Type:  64-bit Operating System, 
> x64-based processor
> 
> I also submitted a question to an IBM Jazz user forum and was told that the Windows Event
viewer is indicating that the JVM cannot be started because it cannot find a file that is
needed.  The user suggested that since my Tomcat and jvm are installed in "C:\Program Files"
that perhaps it is a path issue.  I have checked all paths and have even changed all references
to "PROGRA~1".  When I installed the service, I ran the install from a Windows Command Prompt
that I opened using "Run as Administrator".
> 
> Since Tomcat will start fine from the command line batch files, this is perplexing. 
Has anyone ever run into this?

Is it possible that you have the 32-bit service runner? That would cause the JVM to run in
32-bit mode when you launch as a service. Selecting the JVM DLL directly should definitely
select the right JVM (and
architecture!) but I'm not an expert on Windows and Windows Services.

-chris

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

Mime
View raw message