tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aurélien Terrestris <aterrest...@gmail.com>
Subject Re: AW: Problems to configure tomcat as windows service
Date Thu, 08 Oct 2015 15:13:17 GMT
Arno, can you try with these parameters : --StdOutput out.txt --StdError
err.txt and check if this writes anything to these files (I don't bet a
pence on this but let's try) ?

Taken from the doc :
http://tomcat.apache.org/tomcat-7.0-doc/windows-service-howto.html



2015-10-02 17:52 GMT+02:00 Arno Schäfer <Arno.Schaefer@sqs.com>:

> André,
>
> > Maybe it is not only the version of Tomcat that has changed, but also
> the machine/OS on which
> > you do this ? Maybe the user under which you execute this command does
> not have the
> > required
> > privileges, at OS level on this machine, to do this ?
>
> On the same machine/OS it work's with tomcat 6.
>
>
> > Maybe the user-id *to* which you are trying to set the Tomcat service,
> does not have enough
> > privileges to "run as a Service" ?
> > (In the services.msc applet, it would ask you interactively to grant
> these privileges first, but
> > maybe the command-line tool cannot do that).
>
> Like I said in my first mail, I install it as an local administrator and
> the service was registered and I am able to run it under the local system
> account.
> And also if I fill in the user data manually, what I used in the
> tomcat7.exe call, I am able to start and run the tomcat server, so missing
> privileges shouldn't be the problem.
>
> Regards
> Arno
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message