tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saurav Maulick <saurav...@gmail.com>
Subject Re: Tomcat bad char issue with new cluster
Date Wed, 07 Oct 2015 00:03:11 GMT
No Mikel we don't have any filter in conf/web.xml.



On Tue, Oct 6, 2015 at 3:14 PM, Mikel Ibiricu <jlumietu@gmail.com> wrote:

> Do you have any filter defined in conf/web.xml in the old ones which run
> properly?
>
> Regards,
> Mikel
> El 06/10/2015 15:37, "Saurav Maulick" <saurav85m@gmail.com> escribió:
>
> > Hi Christopher,
> >
> >
> > Please find my answer below
> >
> >
> > *Two new clusters or two new nodes added to an existing cluster?*
> >
> > Two Nodes
> >
> >
> > *What is the difference between the conf/server.xml on a "working" server
> > and one of these new servers that is misbehaving?*
> >
> > No difference. Apart from Server port –Configuration, non-SSL
> > HTTP/1.1Connector port Configuration, AJP 1.3 Connector port
> Configuration,
> > and jvmRoute Configuration
> >
> >
> > *Identical WAR files deployed to all servers?*
> >
> > Yes all the nodes have identical WAR file
> >
> >
> > On Mon, Oct 5, 2015 at 9:06 PM, Christopher Schultz <
> > chris@christopherschultz.net> wrote:
> >
> > > -----BEGIN PGP SIGNED MESSAGE-----
> > > Hash: SHA256
> > >
> > > Saurav,
> > >
> > > On 10/5/15 12:23 PM, Saurav Maulick wrote:
> > > > I know Tomcat 5.5 is very old and this is outdated, but we are
> > > > still using Tomcat 5.5 and we got an issue. Please help.
> > > >
> > > > Problem description:
> > > >
> > > > Recently my client has asked me to add two new clusters in the
> > > > production, after adding the clusters we found that these two new
> > > > clusters are not able to handle special characters.
> > >
> > > Two new clusters, or two new nodes added to an existing cluster?
> > >
> > > > When user copies some data (especially from MS-Word which contains
> > > > double quote) and paste into the application we have found that
> > > > double quote becomes junk character, but these problems only
> > > > persist with newly created clusters not with old clusters.
> > > >
> > > > While creating the new cluster I just copied the old cluster folder
> > > > and all the clusters are identical except some changes in
> > > > server.xml.
> > > >
> > > > Could you please help me to resolve this issue?
> > > >
> > > > NB. UTF-8 char encoding present in the xml files
> > >
> > > What is the difference between the conf/server.xml on a "working"
> > > server and one of these new servers that is misbehaving? Identical WAR
> > > files deployed to all servers?
> > >
> > > - -chris
> > > -----BEGIN PGP SIGNATURE-----
> > > Comment: GPGTools - http://gpgtools.org
> > >
> > > iQIcBAEBCAAGBQJWEx6mAAoJEBzwKT+lPKRYPzIP/iFpPGH+zfPOsgwtqhnqe5ou
> > > 5PqaVEJ0G9+854Gs+q19n9Fcug2NHCnjRaDHj/ujhiOjj2phF1KbWtvEOmMeH6rG
> > > QpuPTPr6DJZiEZpnvCaK2tolQEwnO7CqJ1AEqQo/TQ7IzKFx+Ou5SxZ9m8kQeBKg
> > > ZrPt4vBxrASaELSn+vPPzsA2aBzr9OXijO35Gbjf09FCbR7BC/QnucbAaS6b3z2W
> > > jxrFDRzv7QTxSoA9c8QdNPdcJXEbLQF59yf/4JO/Bx68A7apneSWjo9zw9POWfD2
> > > wHysHZJFF8WBbh1lBJXFuyLMT9luu1v4I7nvdYU98S2p9EOqVTnDM84XBVN9xd/r
> > > TbNGvcIErLsXeNRqHaXSCF95KbjMSdeKCYKfroPz9/xEZUWWpdFRm6OLVTY6mF1F
> > > WDJZUltgGT/O6iM0x39rcEnwapX5XUlPgpolhhEJFC4PXZgLpwQQTwhEBACtClVn
> > > 30P4brBZYIW1NIR4Vq7yI0ltpf7CT0X3Y7xSvP53yM5zIpcmwQsWVCnle+8XY9bz
> > > 4msgAfpp5Xb2q3ovGwrCKahWCeddTofUfgqCBmg7fgvD7K7812rSgjOQ617QgNl5
> > > FZnt9Td79vcWe7I8J1vJdvWTymuydfVMWEu5ptOpORwsGdWVYI/qnOTCl+b8XW7K
> > > oVU1afvuvfBA+abbnz/L
> > > =e9Is
> > > -----END PGP SIGNATURE-----
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> > >
> >
> >
> > --
> > Thanks and Regards,
> > Saurav
> >
>



-- 
Thanks and Regards,
Saurav

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message